Dnsmasq local hostnames with IPv6

Nazar78

New Around Here
Hi all,

I have the RT-AX86U 386.3_2, recently configured with IPv6 Tunnel 6rd, DHCP and RA enabled but I have issues resolving IPv6 in clients hostnames.

Strange is querying the router's hostname does return IPv6 but not the rest of the clients hostnames:
C:\Users\nazar>nslookup RT-AX86U
Server: RT-AX86U.RT-AX86U
Address: 192.168.1.1

Name: RT-AX86U.RT-AX86U
Addresses: 2400:d803:XXXX:XXXX::1
192.168.1.1

C:\Users\nazar>nslookup MEG-Trident-X10
Server: RT-AX86U.RT-AX86U
Address: 192.168.1.1

Name: MEG-Trident-X10.RT-AX86U
Address: 192.168.1.3

Below is my default dnsmasq.conf, I've tried changing the dhcp-range from ra-stateless to ra-names then restarting the daemon:
pid-file=/var/run/dnsmasq.pid
user=nobody
bind-dynamic
interface=br0
interface=pptp*
no-dhcp-interface=pptp*
no-resolv
servers-file=/tmp/resolv.dnsmasq
no-poll
no-negcache
cache-size=1500
min-port=4096
domain=RT-AX86U
expand-hosts
bogus-priv
domain-needed
local=/RT-AX86U/
dhcp-range=lan,192.168.1.2,192.168.1.254,255.255.255.0,86400s
dhcp-option=lan,3,192.168.1.1
dhcp-option=lan,6,192.168.1.1,8.8.8.8,0.0.0.0
dhcp-option=lan,15,RT-AX86U
dhcp-option=lan,252,"\n"
ra-param=br0,10,600
enable-ra
quiet-ra
dhcp-range=lan,::,constructor:br0,ra-stateless,64,600
dhcp-option=lan,option6:23,[::]
dhcp-option=lan,option6:24,RT-AX86U
dhcp-authoritative
interface=br1
dhcp-range=br1,192.168.101.2,192.168.101.254,255.255.255.0,86400s
dhcp-option=br1,3,192.168.101.1
interface=br2
dhcp-range=br2,192.168.102.2,192.168.102.254,255.255.255.0,86400s
dhcp-option=br2,3,192.168.102.1
addn-hosts=/etc/hosts.dnsmasq
dhcp-name-match=set:wpad-ignore,wpad
dhcp-ignore-names=tag:wpad-ignore
dhcp-script=/sbin/dhcpc_lease
script-arp

How can I have IPv6 returned in the local clients queries without putting static names in the host file or using address=/foo/bar? Appreciate any advice, thank you.
 

SomeWhereOverTheRainBow

Part of the Furniture
Hi all,

I have the RT-AX86U 386.3_2, recently configured with IPv6 Tunnel 6rd, DHCP and RA enabled but I have issues resolving IPv6 in clients hostnames.

Strange is querying the router's hostname does return IPv6 but not the rest of the clients hostnames:


Below is my default dnsmasq.conf, I've tried changing the dhcp-range from ra-stateless to ra-names then restarting the daemon:


How can I have IPv6 returned in the local clients queries without putting static names in the host file or using address=/foo/bar? Appreciate any advice, thank you.
here is an example line for use in dnsmasq.postconf

Code:
pc_replace "dhcp-range=lan,::,constructor:br0,ra-stateless,64,600" "dhcp-range=lan,::2,::500,constructor:br0,slaac,ra-names,64,600" $CONFIG
 

Nazar78

New Around Here
here is an example line for use in dnsmasq.postconf

Code:
pc_replace "dhcp-range=lan,::,constructor:br0,ra-stateless,64,600" "dhcp-range=lan,::2,::500,constructor:br0,slaac,ra-names,64,600" $CONFIG
Thank you very much! After setting this I can start to see the IPv6 in the lookups. I was looking for a solution for quite some time before posting. Thank you again.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top