Does aimesh use a tagged VLAN for wired backhaul?

jea101

Regular Contributor
While setting up aimesh I found that a smart switch blocks the wired connection between the node and
the main router. Does this connection use a tagged VLAN? If it is using a tagged VLAN what is the VLAN ID/number?

I did find that in another post that guest SSID apparently use IDs 501, 502 and 503.
 

OzarkEdge

Part of the Furniture
While setting up aimesh I found that a smart switch blocks the wired connection between the node and
the main router. Does this connection use a tagged VLAN? If it is using a tagged VLAN what is the VLAN ID/number?

I did find that in another post that guest SSID apparently use IDs 501, 502 and 503.

This is not common knowledge. Some switches can interfere... a simple switch may not.

OE
 

bbunge

Part of the Furniture
While setting up aimesh I found that a smart switch blocks the wired connection between the node and
the main router. Does this connection use a tagged VLAN? If it is using a tagged VLAN what is the VLAN ID/number?

I did find that in another post that guest SSID apparently use IDs 501, 502 and 503.
The 501, 502 and 503 are the VLANs for the guest networks. They are used regardless of WIFI or Ethernet backhaul.

Oops! Since there is only one guest propagated to the nodes there should only be two VLANs. Others may have a better answer.
 

OzarkEdge

Part of the Furniture
The 501, 502 and 503 are the VLANs for the guest networks. They are used regardless of WIFI or Ethernet backhaul.

Oops! Since there is only one guest propagated to the nodes there should only be two VLANs. Others may have a better answer.

Perhaps for guest1 2.4, 5-1, and 5-2; or 2.4, 5.0, and 6.0 (?).

OE
 
Last edited:

jea101

Regular Contributor
The fact that someone found 501, 502 and 503 are used for guest suggests/implies they are using Ethernet backhaul through a smart/managed switch.
Running the backhaul through a smart switch is the problem I am trying to solve.
Running a cable across the floor, down the stairwell and across the floor again is not an acceptable long term solution.
 

bbunge

Part of the Furniture
The fact that someone found 501, 502 and 503 are used for guest suggests/implies they are using Ethernet backhaul through a smart/managed switch.
Running the backhaul through a smart switch is the problem I am trying to solve.
Running a cable across the floor, down the stairwell and across the floor again is not an acceptable long term solution.
Partly true. I believe someone has used the Asus Guest VLAN through a managed switch. I tried for several months and failed then I moved on to other adventures.
If you read my prior post you will see that I stated the Asus VLANs were used for WIFI or Ethernet backhaul. Not just Ethernet alone.
 

OzarkEdge

Part of the Furniture
The fact that someone found 501, 502 and 503 are used for guest suggests/implies they are using Ethernet backhaul through a smart/managed switch.
Running the backhaul through a smart switch is the problem I am trying to solve.
Running a cable across the floor, down the stairwell and across the floor again is not an acceptable long term solution.

Maybe this FAQ suggests some things to try.

[AiMesh] How to set up ASUS AiMesh or ZenWiFi Mesh Ethernet backhaul under different conditions ? (Advanced setup with network switch) | Official Support | ASUS Global

OE
 

jea101

Regular Contributor
I have found that what appeared to be a smart switch problem was actually related to trying to use an AC1900P with an AC66U_B1.
Aimesh only uses VLAN tags for the guest network
After I setup Aimesh between two AC1900Ps using an Ethernet cable I was able to connect the node through smart switches.
If not using guest network all you need is two switch ports marked as untagged in the same VLAN (I used VLAN ID 14).
For the guest network to work you must add VLAN 501 and 502 to each switch and mark the Aimesh as tagged in 501 and 502 and untagged in an something other than 501 or 502.
My configuration
Aimesh router (master) "LAN" switch port untagged in 14 and tagged in 501 and 502.
Aimesh node "WAN" switch port untagged in 14 and tagged in 501 and 502.

I am actually connecting through four smart switches with a MOCA 2.5 link between two of the switches.

Router robocfg show

Code:
[email protected]:/tmp/home/root# robocfg show
Switch: enabled
Port 0: 1000FD enabled stp: none vlan: 2 jumbo: off mac: 74:ac:b9:a4:df:f9
Port 1: 1000FD enabled stp: none vlan: 1 jumbo: off mac: 9c:fc:e8:f1:99:bf
Port 2:   DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:00:00:00:00
Port 3:   DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:00:00:00:00
Port 4:   DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:00:00:00:00
Port 5: 1000FD enabled stp: none vlan: 2 jumbo: off mac: b0:6e:bf:32:57:c8
Port 7:   DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:00:00:00:00
Port 8:   DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:00:00:00:00
VLANs: BCM5301x enabled mac_check mac_hash
   1: vlan1: 1 2 3 4 5t
   2: vlan2: 0 5
 501: vlan501: 1t 2t 3t 4t 5t
 502: vlan502: 1t 2t 3t 4t 5t
[email protected]:/tmp/home/root#


Node robocfg show

Code:
[email protected]:/tmp/home/root# robocfg show
Switch: enabled
Port 0: 1000FD enabled stp: none vlan: 2 jumbo: off mac: b0:6e:bf:32:57:c8
Port 1:   DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:00:00:00:00
Port 2:   DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:00:00:00:00
Port 3:   DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:00:00:00:00
Port 4:   DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:00:00:00:00
Port 5: 1000FD enabled stp: none vlan: 1 jumbo: off mac: 9c:fc:e8:f1:99:bf
Port 7:   DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:00:00:00:00
Port 8:   DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:00:00:00:00
VLANs: BCM5301x enabled mac_check mac_hash
   1: vlan1: 1 2 3 4 5t
   2: vlan2: 0 5t
 501: vlan501: 0t 1t 2t 3t 4t 5t
 502: vlan502: 0t 1t 2t 3t 4t 5t
[email protected]:/tmp/home/root#
 

truglodite

Regular Contributor
Yesterday I spend some time setting up aimesh between my ax86u and ac86u, and noticed it won't work through my hp smart switch. Fortunately I have structured wiring so it was easy for me to make a direct connection, but learning how to configure vlans on my router with robocfg has been a long time goal for me. So I'm watching this thread...
 

SirusTheVirus

New Around Here
I have actually got this running. But only needing 1 vlan for guests.

Asus router does guest 2.4ghz on vlan501. I tagged ports on my managed switch where the Asus connects and where I have 2 ubiquiti ap's connected.

I then setup exactly the same ssid on my ubiquiti ap's as my Asus guest and set it to use vlan501. Works perfectly. So I have a complete solution with separate ap's with an ssid for guest users on vlan501 across all devices (different vendors).

And all this was achieved without touching the cli where the commands starts getting messy.

And when I had the managed switch with aimesh, the guest network wouldn't work on the node unless I tagged it on the managed switch.
 

jaboda

New Around Here
Thanks for all the tips on this thread - I also got our AiMesh working with a couple of Smart Switches connected together.
We're using one guest network so the trick is to add VLAN 501 as a tagged VLAN to the relevant ports.

You can see what VLANs are needed on the stock firmware by running 'brctl show' in SSH/Telnet.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top