Unbound Does Network Analysis bypass unbound?

Khadanja

Senior Member
I'm running unbound and want to make sure that ISP DNS is not being used. When I do a lookup in Network AnalysisI see the ISP DNS but on local PC I don't. Can someone please explain why Network Analysis is showing ISP DNS?
Server: 203.109.191.1
Address 1: 203.109.191.1 rdns1.ihug.net
Name: www.google.com
Address 1: 2404:6800:4006:812::2004 syd15s17-in-x04.1e100.net
Address 2: 142.250.71.68 syd15s17-in-f4.1e100.net
Running locally-
nslookup www.google.com
Server: UnKnown
Address: 192.168.1.1
Name: forcesafesearch.google.com
Address: 216.239.38.120
Aliases: www.google.com
 

kernol

Very Senior Member
I'm running unbound and want to make sure that ISP DNS is not being used. When I do a lookup in Network AnalysisI see the ISP DNS but on local PC I don't. Can someone please explain why Network Analysis is showing ISP DNS?
Server: 203.109.191.1
Address 1: 203.109.191.1 rdns1.ihug.net
Name: www.google.com
Address 1: 2404:6800:4006:812::2004 syd15s17-in-x04.1e100.net
Address 2: 142.250.71.68 syd15s17-in-f4.1e100.net
Running locally-
nslookup www.google.com
Server: UnKnown
Address: 192.168.1.1
Name: forcesafesearch.google.com
Address: 216.239.38.120
Aliases: www.google.com
Net Analysis on the Router will always use whatever DNS you have told it to use under the WAN settings: -
Mine uses Quad9 instead of the ISP's DNS ...
WAN-DNS.JPG


Your LAN clients will use whatever the client itself has configured - OR whatever DNS Privacy Protocol you have specified on the Router's WAN tab - OR your Unbound Recursive DNS installed on the Router ... both PROVIDED you have set DNSFilter on the LAN tab to the Router.

I no longer run Unbound on my RT-AX86U - preferring to use Quad9 instead as DNS Privacy [DoT].
 

Khadanja

Senior Member
Net Analysis on the Router will always use whatever DNS you have told it to use under the WAN settings: -
Mine uses Quad9 instead of the ISP's DNS ...
View attachment 42001

Your LAN clients will use whatever the client itself has configured - OR whatever DNS Privacy Protocol you have specified on the Router's WAN tab - OR your Unbound Recursive DNS installed on the Router ... both PROVIDED you have set DNSFilter on the LAN tab to the Router.

I no longer run Unbound on my RT-AX86U - preferring to use Quad9 instead as DNS Privacy [DoT].
This is what I have in WAN DNS Settings
1655792848706.png
 

kernol

Very Senior Member
The first line tells it all - you are asking your Router to connect to the ISP's automatically assigned DNS.
If you changed that to "No" you will be given the opportunity to choose another DNS - try "9.9.9.9" which is Quad9's DNS and run your Network Analysis again.

NB - Your router needs to get to a quick and easy DNS server [close by] so that it can perform time sync with the internet and other vital functions. For that reason it is recommended by several far more clued up members than me to just leave the router to get your ISP's DNS [the way you have yours set up now].

With you running Unbound - you do not need to use the DNS Privacy Protocol - so "None" is fine for that.
Your clients will use Unbound as long as the DNSFilter Tab under LAN page is set to Router.

EDIT: If you return to 386.7 your WAN settings will look more like mine above- You must then click the Assign button and chose your ISP's DNS or any of the other ones listed in the pop up window which displays a little lower down the page.
 
Last edited:

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top