DoT usage problem

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.
Status
Not open for further replies.

wordlesswind

New Around Here
Hello guys,

I encountered a problem when using DoT: I cannot use a DoT, but the others are working fine.
IP: 101.6.6.6
Port: 8853
Host: 101.6.6.6
I have no problems when using kdig to test, but I cannot use it in R7000 (Firmware 384.19 by Xwrt-Vortex, CEF 1.3.0.7).
kdig -p 8853 +dnssec +tls-ca +tls-host=101.6.6.6 www.cloudflare.com @101.6.6.6
;; TLS session (TLS1.2)-(ECDHE-SECP256R1)-(RSA-SHA256)-(AES-256-GCM)
;; ->>HEADER<<- opcode: QUERY; status: NOERROR; id: 442
;; Flags: qr rd ra ad; QUERY: 1; ANSWER: 3; AUTHORITY: 0; ADDITIONAL: 1

;; EDNS PSEUDOSECTION:
;; Version: 0; flags: do; UDP size: 4096 B; ext-rcode: NOERROR

;; QUESTION SECTION:
;; www.cloudflare.com. IN A

;; ANSWER SECTION:
www.cloudflare.com. 300 IN A 104.16.123.96
www.cloudflare.com. 300 IN A 104.16.124.96
www.cloudflare.com. 300 IN RRSIG A 13 3 300 20201130074129 20201128054129 34505 www.cloudflare.com. sVwSyLLAL0J4Gk0jLn4gGzV4M/fVhwM1wXV30ZKjzj6nCZFaheqznbbguFI4epLJLOCWOWGs1CX03n8wvQ94Dw==

;; Received 193 B
;; Time 2020-11-29 14:41:29 CST
;; From [email protected](TCP) in 286.1 ms
I don't know how to test in Router, can someone help me?
I know I should go to Xwrt-Vortex for help, but I think this should not be a problem with third-party content.
And I can use Google and Cloudflare's DoT services normally, but this one does not work.

This DoT does not have a domain, it only uses IP addresses and IP certificates.
Its DoH: https://101.6.6.6:8443/dns-query

Thank you!
 

Zastoff

Very Senior Member
Hello guys,

I encountered a problem when using DoT: I cannot use a DoT, but the others are working fine.

I have no problems when using kdig to test, but I cannot use it in R7000 (Firmware 384.19 by Xwrt-Vortex, CEF 1.3.0.7).

I don't know how to test in Router, can someone help me?
I know I should go to Xwrt-Vortex for help, but I think this should not be a problem with third-party content.
And I can use Google and Cloudflare's DoT services normally, but this one does not work.

This DoT does not have a domain, it only uses IP addresses and IP certificates.
Its DoH: https://101.6.6.6:8443/dns-query

Thank you!
Don`t know about your router and firmware.. Suggest a Netgear firmware for your router, Running a asuswrt firmware on your router is not legal i think.
And looks like you are trying to use a DoH (DNS over HTTPS) server on a DoT (DNS over TLS) setup, It will not work (different DNS protocols).
 
Last edited:

Jack Yaz

Part of the Furniture

wordlesswind

New Around Here
Don`t know about your router and firmware.. Suggest a Netgear firmware for your router, Running a asuswrt firmware on your router is not legal i think.
And looks like you are trying to use a DoH (DNS over HTTPS) server on a DoT (DNS over TLS) setup, It will not work (different DNS protocols).
I just said that it also provides DoH, not that I am trying to use DoH on DoT :)
 

Vexira

Part of the Furniture
I just said that it also provides DoH, not that I am trying to use DoH on DoT :)
id suggest buying an asus router if you would like to use the merlin fimware, otherwise reflash back to netgear stock i also suggest that you read that notice posted about the firmware your running being illegal.
 
Status
Not open for further replies.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top