Download speeds really low with SB6190 and RT-N66W

halhawkins

New Around Here
So I recently upgraded from a Arris CM820 to the Arris SB6190.

I run it to an ASUS RT-N66W Wireless router.

When I wire directly from the ASUS to my PC, I only get 6-20mbps download (my service is for 200 mbps) but good upload speeds of 21 mbps. Its also slow wirelessly.

When I wire directly from the SB6190 to my PC, I get 200mbps.

I was getting 200 mbps from the CM820 -> ASUS -> before that. I have bought 2x SB6190's with no success.

I've tested it wired with 2 PCs and no change in download speeds. I've spoken with Suddenlink and Arris and they say its an issue with the ASUS. The ASUS rep was impossible to understand, so that went nowhere.

I've tried enabling Qos as well but that didnt do anything.

What could be causing the slow downloads with the SB6190 when the CM820 worked just fine with the ASUS?

Thanks in advance
 

ColinTaylor

Part of the Furniture
I've tried enabling Qos as well but that didnt do anything.
I was just about to suggest that you make sure that QoS is not enabled as that can sometimes create anomalous speeds issues like this.

What firmware version are you using on the N66W?

Have you tried doing a factory reset on it and setting it up again (do not reload old settings from a backup file)?
 

halhawkins

New Around Here
Yes I did a factory reset

Firmware 3.0.0.4.382_52272-g73d3ea2

I've tried 2x SB6190s as well

I reconnected my old modem and things were fine through the modem. I just wanted to upgrade because I wanted to upgrade my service beyond the 200 mbps service I was getting.
 

ColinTaylor

Part of the Furniture
Given the strangeness of the issue I would be tempted to go back two firmware releases and see if that changes anything.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top