Solved dsl-ac68u dsl port wifi speed problem

cenktezcan

New Around Here
i had 100 mb/10 mb vdsl connection . (via phone cable ) . with lan cable i get the exact download speeds 10 mb/s. but with 2g or 5g i doesnt pass 6 mb/s on pc. i tired on my android device with same results. i have tried all the 5g channels nothing changed. local same network file transfering no problem it gets 30 mb/s . 802q enabled. i had the latest firmware. hard reseted. nothing changed. i have googled it and read all the threads.


 
Last edited:

degrub

Very Senior Member
11,333 MBytes/sec ~ 91 Mbits/sec This is about the practical max given protocol overheads for the ISP wired connection at 100/10 Mbit/sec.

5,404 MBytes/sec ~ 43Mbits/sec

Not sure what the last snip is, but that appears to be the link rate for the wireless connection between the client device and the 5GHz radio. 30 MBytes/sec transfer rate between two wireless clients would be about right ( ~240Mbit/sec ) since wireless is half duplex. What are you using to test this ?
iperf is good for LAN-LAN or LAN-AP testing.

QOS or other settings are likely hurting the AP to WAN or WAN to AP transfer rate. Turn them off, reboot, and test so you get a baseline max.

If you have recently updated the firmware ( you should be on the latest if possible), make sure you factory reset after the update and manually configure if you want to avoid strange issues.

What firmware is it running ?
What is the full model # and version ?
 

cenktezcan

New Around Here
Thank you for your reply. firmware i am using : 386.5_2-gnuton0 . i disabled all qos and other settings. i trying to downloading a 1gb null file. i tried downloading torrents file but the results are same. i installed downloader to my android device (s22 ultra ) the speed is the same 6mb . i had another laptop with ac card same results . i did hard factory reset and didnt work. i dont know old firmware works or not because i had dsl connection at that time (10/1 dl up ). lan to lan over wifi works flowless. i think the problem is dsl port to wifi . i dont have other vdsl modem to bridge to wan port. is it ok to downgrate firmware to try ?
 

degrub

Very Senior Member
disable all wireless types except -AC if you can. If you have -N, ok. for sure disable -a,b, and g
turn off MIMO and any Beamforming if you can.

If you have two laptops with wireless AC, download iperf and test wireless laptop to wireless laptop over 5 GHz band.

The fact that you can get 91 Mbits/s across the WAN to LAN connection, indicates the connection to the ISP is ok.

Using a wifi AC ( laptop), run speed tests across the internet , maybe your ISP has one ?

Since this is a Merlin fork, you may get more answers in the Merlin subforums,
 

cenktezcan

New Around Here
i disabled a-b and g. turned off mimo and beamforming. with 2 laptops both connected ac i made file transfer and speed was about 25 mb . in router build in speed test is 9.2 mb. i will try another router with lan cable . ac68u to router b with cable . i will connect router b wifi and check. Again checked with my android phone again same results. link rate is 526 mbps .

 

degrub

Very Senior Member
i assume 25Mb is 25 MByte ( note use of capital B to indicate Bytes) ~200Mbit/s. Since this transfer is half duplex that is reasonable given the link rate of 526 Mbit/s

That 6.23 MB/s ~ 50 Mb/s, about half of the ISP promise. That is from the router direct to the test server ?
or is that from the phone or laptop ?


What is the wireless environment ?
Do you neighbor's signals interfere with your wireless ?

it doesn't take much interference or overlap to slow things down. Also, the laptop itself can be a bottleneck.
Both laptops have direct line of sight to the router ?
They will be competing with each other for the AP radio. Looks like the QOS may help a little for radio sharing.
the reason to use iperf for local testing is to avoid file transfer protocol and system slow downs to/from disk/SSD on each machine..
 

cenktezcan

New Around Here
iperf test results local network one is connected via rj45 1gb other is connected via 5g . link speed is 866 mb/s
1652046336072.png
 

cenktezcan

New Around Here
it isp reletated . configuration of my vdsl on isp side was set to low latency for gamers. now it is not. i have 10 more ping but problem is solved. i still dont understand how it is releated to wifi.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top