DSL-AC68U slow download, fast upload Wifi on Windows only

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.


New Around Here
Hello everyone!

I just moved houses to a place where internet connection is VDSL 100/10 Mb/s. My DSL-AC68U worked fine in previous house (ethernet). Now the download speed on every windows computer is 0,5 to 2 Mb/s, upload over 10 Mb/s. If i use LTE modem or phone hotspot, download speed is over 50 Mb/s with the same computers.

Every other device (Macbook, Android phone, iPad) has 50-90 Mb/s download speed with this ac68u.

So the problem is: slow wifi download speed (but normal upload speed) only on windows computers.

I have reseted to factory settings, tried a couple of firmwares, tweaked every possible setting including links mentioned on this forum about the same issue.

I found tens of questions in finnish and in english about the same issue.

In the finnish forums the only people who have solved this have installed older firmware version:

Problem is that it is so old i cant find it anywhere, asus has dumped it years ago.

So if you could help me find that firmware version somewhere ! would be very grateful. Thanks in advance!


Part of the Furniture
Don't be looking for old versions. That is a bad idea.

Rather, look for the @GNUton fork of the RMerlin firmware instead.

Flash it, perform a full reset to factory defaults. Do not use a saved backup config file.


Senior Member
Moi Cynthia!
Are you from Finland? :D Great country!
The DSL-AC68U has WIFI 2.4 and 5 Ghz. The latter is much faster than the first one, so first of all check what kind of network adaper you ahve on your windows hardware.
I do have an old linksys Wifi G network adapter which has real problems with the DSL-AC68U, it gets really slow and it throws a lot of errors only when connected to the DSL-AC68U.

I do still need to figure out how to get it properly working. In any case my suggestion is not to look for old firmware which could be vulnerable to worms and hackers and spend 2 euros on aliexpress to buy a newer network adapter (or 10 euros from verkkokauppa).


New Around Here
Thank you both so much already! I'm at work at the moment but gonna try this later today or tomorrow evening :)

Yea finland is pretty nice, but so was Italy when i visited.

Our windows computers are pretty old, so they support only the 2.4 Ghz. Maybe its time to upgrade that side too a bit. I'll let you know how it went!


New Around Here
Hmm I think I may be experiencing the exact same issue. If so it's definitely not down to 2.4/5Ghz.
Do your phones run at full speed also?


New Around Here
You might also look at this recent thread(s), where @zeiphon found a setting that impacted downstream throughput on DSL-AC86U, and seemed to impact download speeds ("enable 802.11Q") for just a laptop. Your issue sounds similar. Oh Nice, zeiphon just replied on this thread too!

Also you should check what WiFi Rx/Tx (radio physical-layer link) rates your laptop is reporting for the connection to this router (Win10 > Settings > Network & Internet > Status > "View hardware and connection properties" (link) > scroll down to wifi adapter and look at "Link Speed:"



New Around Here
Looking to resolve this same issue. I am on a AC68P - Firmware . Not seeming to find any options around 802.11q in WAN settings or other. Asus FAQs not shining any light on the topic either. Thoughts on alternate names\locations for this config option?

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!