Enabling user scripts on AiMesh Node

Christian_Haitian

Occasional Visitor
My rt-ac68u unit started having issues on the 5ghz band so I took it as an excuse to get a new AP and give aimesh another try. I purchased a rt-ax58u unit to add as a aimesh node to my existing rt-ac1900prouter. All seems to be going very well network performance wise so far. I would like to disable the LEDs on the ax58u. I have found how to do this via ssh manually but when I try to automate this by entering the commands in the services-start file in jffs/scripts directory, the services-start does not run on boot. I made sure the shebang was at the top of the services-start file and made sure the services-start file was executable. It seems as if the user scripts are not enabled to be executed. Anybody know how to enable userscripts from SSH since the web interface is not available on the node?
 

JDB

Very Senior Member
I think mine were just enabled, I assumed because they were enabled on the master (most settings are passed over to the nodes it seems).

The alternative would be to use SSH keys to have the master router run a cru job to periodically log into the node and disable LED’s via remote SSH command.

Is there no LED button on that model (there is on all my Asus routers but not looked into the newer ones)? That’s how I turned the LEDs off on my node in the lounge and it persists a reboot.


Sent from my iPhone using Tapatalk
 

Christian_Haitian

Occasional Visitor
I think mine were just enabled, I assumed because they were enabled on the master (most settings are passed over to the nodes it seems).

The alternative would be to use SSH keys to have the master router run a cru job to periodically log into the node and disable LED’s via remote SSH command.

Is there no LED button on that model (there is on all my Asus routers but not looked into the newer ones)? That’s how I turned the LEDs off on my node in the lounge and it persists a reboot.


Sent from my iPhone using Tapatalk
Unfortunately, the ax58u does not have a physical LED button. I might look into setting up a cronjob to do this in the future. Since the node is mostly out of sight, I decided to implement an easy less automated solution by using black electrical tape. The unit is black as well so it works for now.
 

Yota

Very Senior Member
First make sure that your node is running merlin firmware, because only merlin firmware can custom scripts and config be used.

Enable "SSH LAN Only" on your main router, then it will sync this setting to the node router.

Then use SSH client to login to your node router, and enter this command to enable custom script and config support for the node router:
Code:
nvram set jffs2_scripts="1"
nvram commit
Then enjoy!
I always recommend disabling the ssh after you use it. this will be a safe and good habit.

BTW, I suggest using your AX58U as the main and AC68U as the node, so you will get better performance and benefit from the 68U physical led switch.;)
 
Last edited:

crespoe1

New Around Here
First make sure that your node is running merlin firmware, because only merlin firmware can custom scripts and config be used.

Enable "SSH LAN Only" on your main router, then it will sync this setting to the node router.

Then use SSH client to login to your node router, and enter this command to enable custom script and config support for the node router:
Code:
nvram set jffs2_scripts="1"
nvram commit
Then enjoy!
I always recommend disabling the ssh after you use it. this will be a safe and good habit.

BTW, I suggest using your AX58U as the main and AC68U as the node, so you will get better performance and benefit from the 68U physical led switch.;)

Hi. I have a AC-86u as main router , an ac66u b1 and 2 Lyra mini as a mesh network. Both 86u and 66b1 are using Merlin firmware. When I try to SSH the 66b1 with the main router credentials I get wrong password form the 66b1. Have I done something wrong ? Thanks
 

Begotten

Occasional Visitor
My rt-ac68u unit started having issues on the 5ghz band so I took it as an excuse to get a new AP and give aimesh another try. I purchased a rt-ax58u unit to add as a aimesh node to my existing rt-ac1900prouter. All seems to be going very well network performance wise so far. I would like to disable the LEDs on the ax58u. .....

Do you know that you can disable/enable the leds on a node by just go to the Web GUI -> AiMesh -> Select the node -> Management -> LED (Radio button On/OFF)
 

Tech9

Part of the Furniture

Yota

Very Senior Member
Hi. I have a AC-86u as main router , an ac66u b1 and 2 Lyra mini as a mesh network. Both 86u and 66b1 are using Merlin firmware. When I try to SSH the 66b1 with the main router credentials I get wrong password form the 66b1. Have I done something wrong ? Thanks
I'm not very sure, I don't use AiMesh anymore, because it's not as stable as I thought, I used to use SSH Key to log into the main router and nodes, SSH Key will be synced between these routers, maybe you can try SSH Key.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top