Entware deluge segmentation fault on start up

marcovanb

New Around Here
I recently got an rt-ac86u and installed merlin version 384.17 on it.

I set it up running entware and deluge as I need deluge for socks5 proxy functionality. It was working as expected. I then attempted to get openvpn running for external access and made a mess of my router settings. That was 3 weeks ago.

To clean up the router I did a factory reset and reformatted 8gb usb drive. I created a 2gb swap file using amtm on the thumb drive.

Then I installed entware via amtm and then deluge. Now deluge fails to start and I get a segmentation fault.

[email protected]:/tmp/home/root# /opt/etc/init.d/S80deluged start
starting deluged
Segmentation fault

When the post install script runs I get:

[email protected]:/tmp/home/root# /tmp/mnt/usb_drive/entware/lib/opkg/info/deluge.postinst
Setting default deluge ui to console ...
Unable to initialize gettext/locale!
'ngettext'
Traceback (most recent call last):
File "/opt/lib/python3.8/site-packages/deluge/i18n/util.py", line 118, in setup_translation
builtins.__dict__['_n'] = builtins.__dict__['ngettext']
KeyError: 'ngettext'
Segmentation fault

Also, the folder /opt/etc/deluge/.configured is empty

Thanks for any feedback
 
Last edited:

immi803

Regular Contributor
I recently got an rt-ac86u and installed merlin version 384.17 on it.

I set it up running entware and deluge as I need deluge for socks5 proxy functionality. It was working as expected. I then attempted to get openvpn running for external access and made a mess of my router settings. That was 3 weeks ago.

To clean up the router I did a factory reset and reformatted 8gb usb drive. I created a 2gb swap file using amtm on the thumb drive.

Then I installed entware via amtm and then deluge. Now deluge fails to start and I get a segmentation fault.

[email protected]:/tmp/home/root# /opt/etc/init.d/S80deluged start
starting deluged
Segmentation fault

When the post install script runs I get:

[email protected]:/tmp/home/root# /tmp/mnt/usb_drive/entware/lib/opkg/info/deluge.postinst
Setting default deluge ui to console ...
Unable to initialize gettext/locale!
'ngettext'
Traceback (most recent call last):
File "/opt/lib/python3.8/site-packages/deluge/i18n/util.py", line 118, in setup_translation
builtins.__dict__['_n'] = builtins.__dict__['ngettext']
KeyError: 'ngettext'
Segmentation fault

Also, the folder /opt/etc/deluge/.configured is empty

Thanks for any feedback
+1
 

Twiglets

Senior Member

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top