1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Entware on Asus BRT-AC828

Discussion in 'ASUS AC Routers & Adapters' started by zasqw, Nov 15, 2019.

  1. zasqw

    zasqw New Around Here

    Joined:
    Nov 15, 2019
    Messages:
    3
    Greetings to all!!! There are owners of Asus BRT-AC828? At someone it turned out to put the ENTWARE repository on this router. The entire Internet rummaged, but no information not found. I will be grateful to the one who will help.
     
  2. AndreiV

    AndreiV Very Senior Member

    Joined:
    Aug 25, 2015
    Messages:
    944
    I think the BRT-AC828 router is Intel based , Entware is not compatible.
     
  3. zasqw

    zasqw New Around Here

    Joined:
    Nov 15, 2019
    Messages:
    3
    No, it runs on Qualcomm IPQ8065 platform. The main processor is hardly a novelty, but products with it are rare. This chip is positioned in the segment of "Internet processors" and has two Krait computing cores with ARM V7 architecture, operating at 1.7 GHz, as well as two cores for processing network packets, whose frequency is 800 MHz. As the met post, that can be put ENTWARE, but not explained, as. and the user does not get in touch.
     
  4. zasqw

    zasqw New Around Here

    Joined:
    Nov 15, 2019
    Messages:
    3
    Still, I was able to install Entware on BRT-AC828. Suddenly someone come in handy. Set on the ssd. I have it as sda1:
    Command (without the quotes):

    "mount-o bind /mnt/sda1"

    "ln-sf /mnt/sda1 /tmp/opt"

    "wget -O - http://bin.entware.net/armv7sf-k3.2/installer/generic.sh | sh"
    or
    "wget-O - http://bin.entware.net/armv7sf-k3.2/installer/alternative.sh | sh"

    Then installed the packages I needed:
    Command (without the quotes):

    "opkg install xupnpd"
    "opkg install minidlna"

    Start services manually:
    Command (without the quotes):

    "/opt/etc/init.d/rc.unslung start"
    or
    "/opt/etc/init.d/rc.unslung restart"

    Configured the applications. Everything works fine.....
    BUT...
    ...after restarting the router, the opt/ folder is deleted and Entware does not work. Have to re-install Entware and run packages. Now looking for a script to automatically start Entware.
    I will be glad of any help on the question or any advice.
     
    Grisu likes this.