Entware Tinyproxy not working with firewall enabled

  • ATTENTION! You'll notice a Prefix dropdown when you create a thread. If your post applies to one of the topics listed, please use that Prefix for your post. When browsing the thread list you can use the Prefix to filter the view.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

fava

New Around Here
My router is a AC-68U running the latest Merlin 386.3_2. I set up a tinyproxy server using entware, and it works perfectly if I disable the Merlin firewall. However, if I enable the firewall, tinyproxy stopped working, and the log indicated that tinyproxy didn't receive any incoming packets.

In the config file, tinyproxy is bound to all the IPs, i.e., both the router public IP and 192.168.1.1.

I have tried Port Trigger (in the WAN tab), Port Forwarding (in the WAN tab), and Network Service Filter (in the Firewall tab) without any luck. Any help is appreciated!
 

ColinTaylor

Part of the Furniture
The router's firewall will drop all unsolicited traffic by default. So you need to create an exception for whatever port tinyproxy is listening on using a firewall-start script, and optionally by port forwarding (if using the LAN interface).
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top