ESP8266 and Asus RT-AX88U - Mac showing but not IP

AcidSleeper

New Around Here
Hey guys.

Im having a problem that I havent figured out even with help from another forum.

I made a smart fan from a Sonoff Basic (ESP8266) and first it didnt connect to my router so manually assigned a ip-adress in the esp-code.
It connected and I can communicate with the fan (on, off, fanspeed) so its working, BUT......

When I look in the router it doesn´t show.

In the Wireless-log I only se this: (Where it says "offline" is where the ip-adress should show.
1.jpg


Im running Asuswrt-Merlin 386.3_2
I have both 2.4 and 5 Wifi-networks but they have different names.

My 2.4 Wifi-settings:
2.jpg


And Wifi Professional
3.jpg


Other settings is: WPS and Mac-filtering is off, DHCP is on, Firewall is on.


This is the ESPHome code in the wifisection:

YAML:
wifi:
  ssid: !secret ssid
  password: !secret wifi_password

  manual_ip:
    static_ip: 192.168.1.5
    gateway: 192.168.1.1
    subnet: 255.255.255.0


Anyone that can think of anything that I might overlooked???

Thanks!
 

AcidSleeper

New Around Here
I can even ping the 192.168.1.5 (ESP8266) from my computer via cmd... and it responds

Even ping from Asuswrt-Merlin and it responds...
 
Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top