Ethernet is slow to identify on ASUS router

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

louwestin

New Around Here
I recently purchased a RT-AX58U and noticed that whenever I restart or turn on my computer that has a direct wired connection to the router, it takes about 20-30 seconds for the network to identify and connect to the internet. Wireless devices/Laptops are instantly connected. My old router which was a different brand didn't do this.

Specs: Running Windows 10, Cable modem NETGEAR CM1000, Internet speeds test at/above the provisioned speeds.

Things I've done so far:

1. Updated the firmware to the latest version: 3.0.0.4.386_45898
2. Rebooted the router and cable modem.
3. Reset the network adapter back to default settings.
4. Double checked the router settings to see if I set anything incorrectly.

Thanks in advance!
 

ColinTaylor

Part of the Furniture
Replace the Ethernet cable between the router and the PC.

Test from a different Ethernet connected PC. Does the same thing happen?
 

ColinTaylor

Part of the Furniture
The only thing I can think of is to check that the Windows network settings are configured as a Private network and not a Public network.

You might have to look in the Windows Event Log for clues.
 

louwestin

New Around Here
Ok. Network is already set to private. When I did the network card reset, it asked if I wanted to turn on net discovery, I said no since I read elsewhere that "might" help, but still have the delay. Probably some issue with Windows. lol

It's just a slightly annoying issue, definitely not a return to the store issue. Once Globe icon is gone, it's fine. I had issues with the other brand router where the last couple of firmware updates were causing known DNS issues and we were no longer getting the provisioned internet speed. It's nice having an ASUS router again.

It's one of those odd issues I run into sometimes where even the best scratch their heads trying to figure it out. lol

Thanks again!
 

ColinTaylor

Part of the Furniture
Yeah, you need to have network discovery on for a private network otherwise you might run into other problems.

If Windows can't connect to dns.msftncsi.com that can cause an issue similar to what your seeing. So if you have DNS issues that will be a problem.
 

W3Wilkes

Occasional Visitor
If Windows can't connect to dns.msftncsi.com that can cause an issue similar to what your seeing. So if you have DNS issues that will be a problem.
I would guess if it's a DNS issue it would be the same for wifi and ethernet. Since this only happens on wired I would think access to dns.msftncsi.com isn't the issue.
 

ColinTaylor

Part of the Furniture
I would guess if it's a DNS issue it would be the same for wifi and ethernet. Since this only happens on wired I would think access to dns.msftncsi.com isn't the issue.
Indeed. But there might be some local DNS settings on the PC or something else installed (like ad-blocking) that might effect DNS.
 

bbunge

Part of the Furniture
Some things to try:
Device Manager/Network adaptors/(brand)Ethernet Connection - Power Management turn off Allow the computer to turn off this device to save power. Under Advanced/Speed & Duplex set to 1.0 Gbps Full Duplex

As a side note I have noticed since upgrading to Windows 11 my Ethernet connection is a bit slow to connect when the PC wakes from sleep.
 

louwestin

New Around Here
Some things to try:
Device Manager/Network adaptors/(brand)Ethernet Connection - Power Management turn off Allow the computer to turn off this device to save power. Under Advanced/Speed & Duplex set to 1.0 Gbps Full Duplex

As a side note I have noticed since upgrading to Windows 11 my Ethernet connection is a bit slow to connect when the PC wakes from sleep.
I changed the adapter settings to turn off power management and full duplex (It was set to auto)

There's still a 20'ish second delay, but at this point I might just say Meh... and let it go. It's not a terrible amount of time to wait and my two kids desktops that wired as well, haven't complained.

Wife runs wireless, so as long as she's not complaining that's really what counts. LOL!
 

louwestin

New Around Here
I figured out what the issue is and how to solve it! I don't know if it's a networking thing or a bug somewhere, but what fixed it was adding a simple switch from the ASUS Router's built-in switch to my computer.

How I figured this out was by looking at my other daughter's computer which is connected to an extra switch and testing her computer. The network is instantly identied. So I pulled it really quick to test on my computer and that resolved the delay issue.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top