1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

exFAT USB SMB permissions problem

Discussion in 'General Wireless Discussion' started by dj045, Jul 15, 2019.

  1. dj045

    dj045 Occasional Visitor

    Joined:
    Jul 7, 2019
    Messages:
    19
    I have a small GL.iNET router that has a USB stick connected and is shared via SMB on my network.

    The USB is formatted as exFAT so that I have read/write compatibility with Windows and Mac should I need to plug the stick into either machine - this works fine no issues.

    The problem I have is that I am not able to write to the USB when it is plugged into the router over the network. If I try I get a 'You require permission from S-1-22-1-0 to make changes to this file.' I can read files that are saved to it already ok though

    I have obviously googled a fair bit and I'm growing to believe I need to be looking at SMB permissions.

    My smb.conf file looks like this

    [global]
    netbios name = |NAME|
    display charset = |CHARSET|
    interfaces = |INTERFACES|
    server string = |DESCRIPTION|
    unix charset = |CHARSET|
    workgroup = |WORKGROUP|
    browseable = yes
    deadtime = 30
    domain master = yes
    encrypt passwords = true
    enable core files = no
    guest account = nobody
    guest ok = yes
    invalid users = root
    local master = yes
    load printers = no
    map to guest = Bad User
    max protocol = SMB2
    min receivefile size = 16384
    null passwords = yes
    obey pam restrictions = yes
    os level = 20
    passdb backend = smbpasswd
    preferred master = yes
    printable = no
    security = share
    smb encrypt = disabled
    smb passwd file = /etc/samba/smbpasswd
    socket options = TCP_NODELAY IPTOS_LOWDELAY
    syslog = 2
    use sendfile = yes
    writeable = yes

    Wondering if someone with SMB configuration experience can point me in a direction that will help me solve this...

    Thanks in advance
     
  2. ColinTaylor

    ColinTaylor Part of the Furniture

    Joined:
    Mar 31, 2014
    Messages:
    9,771
    Location:
    UK
    I have no experience of the GL.iNET but i'd hazard a guess that there's a conflict between the "invalid users = root" statement and the owner of the files, S-1-22-1-0 (which is the SID for root).
     
    dj045 likes this.
  3. dj045

    dj045 Occasional Visitor

    Joined:
    Jul 7, 2019
    Messages:
    19
    Can you elaborate how one might go about resolving this potential conflict, is there something I can check/remove/add to the SMB config?
     
  4. ColinTaylor

    ColinTaylor Part of the Furniture

    Joined:
    Mar 31, 2014
    Messages:
    9,771
    Location:
    UK
    Sorry, no idea. I don't know anything about the GL.iNET or how to configure it. TBH it might not have anything to do with what I said.