[Experimental] Asuswrt-Merlin 384.13 test - AiMesh/DNSSEC through OpenSSL

Status
Not open for further replies.

RMerlin

Asuswrt-Merlin dev
My test setup has a mixture of Merlin (RT-AC86U) and Asus (Lyra Trio) nodes:

upload_2019-7-12_22-39-36.png
 

skeal

Part of the Furniture
Really happy with how this is working out. Just updated my AiMesh AX88U and everything is golden. Nice work Eric!!
 

Gitsum

Senior Member
I still can't get my stuff working right. Got an AC86U today and it wouldn't join as a node via WIFI. It worked fine with an Ethernet cable and then seemed to be working after I unplugged the cable. But after taking it to the other building, just like the AC68U, no clients can connect or get internet through the 2.4 channel.
I am really frustrated with this.
All I really want out of trying to go with AiMesh instead of repeater mode(which works fine) is the ability of my main router (AX88U) is to be able to see all the devices in the device list and for the traffic analyzer to keep track of those devices and the apps they use.
There must be a way to do that without mesh.
 

Kingp1n

Very Senior Member
I still can't get my stuff working right. Got an AC86U today and it wouldn't join as a node via WIFI. It worked fine with an Ethernet cable and then seemed to be working after I unplugged the cable. But after taking it to the other building, just like the AC68U, no clients can connect or get internet through the 2.4 channel.
I am really frustrated with this.
All I really want out of trying to go with AiMesh instead of repeater mode(which works fine) is the ability of my main router (AX88U) is to be able to see all the devices in the device list and for the traffic analyzer to keep track of those devices and the apps they use.
There must be a way to do that without mesh.

You mentioned earlier you were able to link AIMesh wired correct?
 

Kingp1n

Very Senior Member
Once you disconnect the lan cable does it automatically switch to wireless?
 

cmillar6

Senior Member
So I decided to finally give AIMesh a try using my AC88u as the master and a AC68P as the node, both running the newest Merlin 384.13 alpha 2. So far it seems to work just fine, all 25 of my wireless clients report full signal strength throughout the house. My IP cameras much closer to the node than my AC88u master haven't switched over to my node yet, not sure why?
 

skeal

Part of the Furniture
Unable to remotely update the firmware on my AiMesh node. I get this little window instead of a file browser to select the file to upload.
 

Kingp1n

Very Senior Member
Unable to remotely update the firmware on my AiMesh node. I get this little window instead of a file browser to select the file to upload.
Is working for me using both chrome & edge.
 

skeal

Part of the Furniture
The other thing I noticed is: If I reboot the main router, the node never re-attaches. I have to reset the node to defaults and add the node again. Is this par for the course or....?
 

Jack Yaz

Part of the Furniture
Unable to remotely update the firmware on my AiMesh node. I get this little window instead of a file browser to select the file to upload.
Was there supposed to be a screenshot or picture attached?
 

skeal

Part of the Furniture
Was there supposed to be a screenshot or picture attached?
The little window that opens instead of a file browser window, is a miniature browser window, that shows the login page of the master router.
 

skeal

Part of the Furniture
When I click on the node's Upload link it should show a file browser so you can select a file to upload, but it doesn't, it instead launches a small browser window, (in my case Chromium and Firefox), showing the login screen for the node.
 

JoGi

Occasional Visitor
Aimesh on ax88u works great, only have one question.
Before using aimesh my routers were on AP modus (With static ip) And could login on several routers.

Now i’m using aimesh i cant login on any other nodes
When i put the static ip of a second router (x.x.x.253) on webbrowser, it redirect automatic to the primary aimesh router (x.x.x.254) ?
How can i login on the other nodes?
Because i want to see the temperature/cpu load. Etc.. etc..


Fyi
Things in need of testing:
  • Adding/removing a node. ✅
  • Updating the firmware on one of your nodes. (Ac88 & ac68)✅
  • Validate that clients are able to connect to the separate nodes ✅
 
Last edited:

Grisu

Part of the Furniture
I still can't get my stuff working right. Got an AC86U today and it wouldn't join as a node via WIFI. It worked fine with an Ethernet cable and then seemed to be working after I unplugged the cable. But after taking it to the other building, just like the AC68U, no clients can connect or get internet through the 2.4 channel.
I am really frustrated with this.
All I really want out of trying to go with AiMesh instead of repeater mode(which works fine) is the ability of my main router (AX88U) is to be able to see all the devices in the device list and for the traffic analyzer to keep track of those devices and the apps they use.
There must be a way to do that without mesh.
Which channels do you use on your AX? 160MHz disabled, dont use DFS channels.
Change everything to the same you know it is running on your 86U. Factory reset 86U before meshing.
 

Swistheater

Very Senior Member
testing merlin nodes

* note I was able to flash stock node RT-AC68 to merlin without performing reset afterwards.
RT-AC3100 required a reset afterwards because it went offline and did not come back.
The true question is will merlin nodes remain manual update only, or will there be some kind of hybrid method to allow it to check either merlin or stock (in mixed stock and merlin node setups)
 
Last edited:

Kingp1n

Very Senior Member
The other thing I noticed is: If I reboot the main router, the node never re-attaches. I have to reset the node to defaults and add the node again. Is this par for the course or....?
No issues here....i rebooted multiple times as I'm tryin to use DoT with quad9...it's odd you're getting this issues.
 

Gitsum

Senior Member
Which channels do you use on your AX? 160MHz disabled, dont use DFS channels.
Change everything to the same you know it is running on your 86U. Factory reset 86U before meshing.
I use auto channel for 2.4ghz, channel 36 for 5ghz, 160mhz off, HE frames off.
I was able to update the 86U node with Merlins alpha 2 just fine.
I've given up on the 68U as a node for now.
 

Kingp1n

Very Senior Member
Aimesh on ax88u works great, only have one question.
Before using aimesh my routers were on AP modus (With static ip) And could login on several routers.

Now i’m using aimesh i cant login on any other nodes
When i put the static ip of a second router (x.x.x.253) on webbrowser, it redirect automatic to the primary aimesh router (x.x.x.254) ?
How can i login on the other nodes?
Because i want to see the temperature/cpu load. Etc.. etc..


Fyi
Things in need of testing:
  • Adding/removing a node. ✅
  • Updating the firmware on one of your nodes. (Ac88 & ac68)✅
  • Validate that clients are able to connect to the separate nodes ✅
I don't think you can log into the nodes independently even on stock firmware. I believe you can SSH into the node but that's about it.
 
Status
Not open for further replies.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top