Fed up with google home devices being offline or not found

Not open for further replies.


Regular Contributor
The majority of the time I'm looking to cast to one of my devices its not populated in the list. Sometimes google home app can't connect to the device either. AP isolation is off. I'm running an AC88u with Merlin software. Today I factory reset all my home devices, cleared the google home app, restarted the phone, put it in airplane mode. My phone will connect to the home to set it up but when its finished and it connects the home to my network instead of wifi direct to the phone it tells me we aren't on the same network and to turn ap isolation off. We are on the same network, ap isolation is off router has been rebooted. I'm pulling my hair out over here. Any ideas? This happens to 2 google homes, nest mini, nest hub, nest hub max. I've tried using other phones for setup. Very Frustrated!


Part of the Furniture

Matthew Patrick

Senior Member
Is this only happening on the .19 firmware? Because it is happening in mine (AC86U) . I thought it's my google nest mini but no. So my fix would be. Factory reset the Google things you wanna connect. Then reboot the wifi. When it's up. Go ASAP to google home and set it up. When it connects to the wifi etc. It shouldn't error out in AP Isolation anymore . But yes sometimes the casting is not working. It's prob a bug in the new fw. Since mine is exactly the same as yours. It says to turns off ap isolation even tho it is off. Idk why but on the latest version sometimes my devices can't search some local network devices.


Regular Contributor
I'm on .17 but its been happening for a while. I finally got all my home devices reset up and it seems like its been better. I just wish it wasn't so flaky


Occasional Visitor
I don't have google home pod, but I use the home app on android phones and tablets. Most of my issues are around casting audio to receivers using the android devices. The devices are on, and airplay works, google cast does not.

I find that restarting the receivers/speakers by completely unplugging them fixes the problem and google home starts seeing them again, the problems seem to start after rebooting the router or AP. Same for lights etc. Switch off and on again.

Receivers are connected via ethernet or wifi, and the android devices are either 2.4 or 5 ghz wifi.

Why do you think its a router/firmware issue?


New Around Here
Never had any issues with my google home and the connected devices, is it just your router being funky with it or other devices too?..


Regular Contributor
I have a ton of Nest 2nd gen mini speakers, and four of the new Nest Audio speakers The one original nest mini and the four second gens I have will randomly say trying to connect to the internet off and on. I think it's a bug with the original and the 2nd gen nest mini speakers. They either reconnect themselves, or I just unplug and re plug in and good to go. Mayyyyyyybe once a month I run into this. Thermostat and New audios don't have the same issue.
Not open for further replies.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!