Firmware - RT-AC87U

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.


Occasional Visitor
Hi Guys,

I'm looking for guidance and cannot find any information on FAQ.

I have firmware Asus Merlin 384.13_8 installed on my router AC-87U.

I tried to re-install the firmware provided by Asus. Installation starts and router reboots successfully. However after reboot the firmware version is still Asus Merlin. How can I remove this and install the firmware provide by Asus here :


Part of the Furniture
Remove any USB devices.
Reset the router to factory defaults and perform only the mandatory minimum setup.
Then re-flash the Asus firmware.

If that works perform another factory reset before manually setting up your router.
  • Like
Reactions: Sky


Occasional Visitor
Hi Guys,

I have firmware Asus Merlin 384.13_10 installed on my router RT-AC87U, hoping the issue with goes away. I get an error on Safari stating that:

Safari ErrorChrome Error
Safari - error.png
Chrome - error.png

However if I hit the apply button on WAN >> Internet Connection at the bottom without making modifications the error temporarily goes away. I have also tried DNS over TLS and hit apply. That works also for a few minutes. Then the error comes back again.

I have tried to clear cache and all sort of other suggestion on the internet. The only fix for me is to run "apply button" that would allow me to open the page. But after a few minutes the error is back.

Any suggestions ? what could be the root cause ? This is fairly new - recently (last 2 months or so).

WAN - screen 1.png

WAN - screen 2.png

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!