1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

FTP Port Forward Question

Discussion in 'Routers' started by Mark070, Mar 29, 2020.

  1. Mark070

    Mark070 Occasional Visitor

    Joined:
    Nov 18, 2019
    Messages:
    29
    Location:
    Minnesota, USA
    Hey Guys,

    Was setting up a quick FTP Server on my Synology NAS. I was having difficulty with trying to connect to the FTP server (NAS) over the internet, as in, it could not.

    I could connect just find on the local network, just not through the WAN interface.
    I ultimately was able to get it to go using SFTP (port 22), but why would FTP over TLS (port 21) not work?

    I have attached my Synology setup as well as my Edge Router Port forwarding page. I have both ports forwarded correctly, but cannot connect through port 21
     

    Attached Files:

  2. ColinTaylor

    ColinTaylor Part of the Furniture

    Joined:
    Mar 31, 2014
    Messages:
    11,663
    Location:
    UK
    You also need to forward the PASV ports 55536:56047 if the NAS doesn't do that automatically via UPnP.
     
  3. Mark070

    Mark070 Occasional Visitor

    Joined:
    Nov 18, 2019
    Messages:
    29
    Location:
    Minnesota, USA
    Yup, tried that as well. Filezilla stayed at Attempting to Connect... would not connect (over the WAN)
     
  4. ColinTaylor

    ColinTaylor Part of the Furniture

    Joined:
    Mar 31, 2014
    Messages:
    11,663
    Location:
    UK
    Filezilla can be rather unforgiving with non-compliant servers. Just saying....

    Change Filezilla's debug setting from 0-None to 2-Info. That should show you what's happening.
     
  5. ColinTaylor

    ColinTaylor Part of the Furniture

    Joined:
    Mar 31, 2014
    Messages:
    11,663
    Location:
    UK
    Also... Tick the "Report external IP in PASV mode".