GT-AXE11000 firmware update - cannot flash back to original functionality

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

timg11

Occasional Visitor
My GT-AXE11000 came with firmware 3.0.0.4.386.42026. This was reported in the UI.
It allowed operation with "Open System" in the 6 GHz band.

I saw that firmware 3.0.0.4.386.42489 was available. I downloaded the original firmware as well as a backup in case of any regressions.
The newer firmware changed the UI for the Wireless Settings for 6 GHz. Only WPA3 and OWE are available.
I know those are the standard for Wi-Fi 6E, but for the moment with early stage drivers, they are not adequately supported.
Unfortunately my Ubuntu client with AX-210 that was working with Open System previously will not connect to the Asus with WPA3 or OWE (despite those features theoretically being supported in Ubuntu 20.04) (Yes I've tried the nmcli process described here, and it does not solve the issue)

I tried to flash back to 42026, but the wireless settings remain as they were with 42489.
I performed a Reset Factory Defaults, loaded 42026 again, and reload loaded the configuration saved with the original firmware.
Still the wireless settings do not offer Open System.

Has anyone else seen this? Is it possible that the 3.0.0.4.386.42026 provided on the Asus web site is different than the 3.0.0.4.386.42026 that was shipped in the router?
Or is there some other setting that I've missed?
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top