Guest Network screen bug when using an emoji in 2.4GHz SSID on RT-AX58U Firmware Version: 386.7_2 (since 386.3_2)

dragoworld235

New Around Here
Hi,

I’ve got this bug since updating my router from 386.1_? to 386.3_2 ( https://www.snbforums.com/threads/asuswrt-merlin-386-3-is-now-available.73815/post-708137 ).
Today I finally factory reset my router to fix it as I thought it was a dirty update problem.
But I triggered the bug even after reset.
You can see it on my screenshots (I just edit them to remove the password field).

When adding the 2.4 guest network 2, the 5 zone disappears.
Disabling it or changing the SSID to something else fixes it.
If the is in the 5 zone, it does not disappear.
The Facebook Wifi zone is also here, or not…

2022 08 03 154839 - firefox.png


2022 08 03 154948 - firefox.png

2022 08 03 155125 - firefox.png

2022 08 03 155352 - firefox.png

2022 08 03 155415 - firefox.png

Last image in next message.
 

RMerlin

Asuswrt-Merlin dev
This is generally caused by a Javascript error. Open your browser console and post the error message.
 

dragoworld235

New Around Here

RMerlin

Asuswrt-Merlin dev

dragoworld235

New Around Here
How long are your SSIDs and passphrases?
Guest Host 2.4:
SSID=<owl emoji>2
password= 60 char
(As seen on a screenshot, when I change the SSID to "auie" without changing the password, the 5 GHz zone is visible)

5 GHz guest:
SSID=<owl emoji>5
password=63 char
 

L&LD

Part of the Furniture

Point 7 seems relevant here.
 

RMerlin

Asuswrt-Merlin dev
Could be that the QRcode generator isn't Unicode-capable, in which case there isn't much I can do about it. It's just odd that the code length overflow seem to indicate the code is over twice larger than what is supported.

EDIT: Yep, it's an issue with the QRcode library.

 
Last edited:

dragoworld235

New Around Here
Could be that the QRcode generator isn't Unicode-capable, in which case there isn't much I can do about it. It's just odd that the code length overflow seem to indicate the code is over twice larger than what is supported.

EDIT: Yep, it's an issue with the QRcode library.

And you have added the qrcode in 386.3 which match with the upgrade where I noticed the problem (386.1_? to 386.3_2).
While testing today I found the workaround to temporarily get the 5GHz zone back by disabling the 2.4 guest network with the emoji. So I can live with it as it will be too much trouble to change my SSID on every devices.
Thanks.
 

L&LD

Part of the Furniture
You're painting yourself into a corner that you'll sooner or later, have to walk out from. :)
 

RMerlin

Asuswrt-Merlin dev
I found a fork for the qrcode library that adds Unicode support. Works fine for me now when I add an emoji in my SSID, so I will switch to that forked version.

While supported, i don't recommend using emojis. It will eventually bite you the day you try to use a client that does not support them, or you are using a device asking you to manually type the SSID.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top