GUI does not work when you assign a DNS , cannot access options.....


New Around Here
When I attempt to assign a DNS server under WAN setting, the window for the DNS options is not available, the new option screen appears set behind the initial screen.
Last edited:


Part of the Furniture
Welcome to the forums @MerasusRtAx58u.

Can we assume this is for an RT-AX58U? :)

Does clearing the browser cache help? Does using another browser help? Does using the browser in 'safe mode' work better?

What firmware are you using? What other features/options and scripts are you running?

You may want to ask a moderator to move this thread for you from the Suggestion Box forum too.


New Around Here
Hi there - thanks for your reply. Yes my name gives you some clues :) I am using a RT-AX58U running 386.7 firmware.

Clearing the cache didnt help.... I am running in AIMESH mode with an RP-AX56 node, running a firmware, wireless backhaul.

The laptop I am writing this response on does not connect to the Asus GUI site unless I connect Incognito mode. Maybe the Incognito mode is the problem, I will try another laptop to see if the DNS is working. I don't understand why I have to connect in Incognito mode.....

I am new to this forum, so not sure which forum I should post this.....



Part of the Furniture
Do you have any adblocker enabled that is disabled in Incognito mode? Try excluding the router URL from the adblocker. Or any errors in the browser F12 console?


Senior Member
It may be simpler than this! If you are using a small screen, you may need to just scroll down to see the initially hidden dialogue that's opened up

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!