1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Having issues with SIP Voip when CTF enabled on RT-AC5300 / Merlin 384.7

Discussion in 'Asuswrt-Merlin' started by Tlex, Oct 10, 2018.

  1. Tlex

    Tlex Occasional Visitor

    Joined:
    Mar 7, 2017
    Messages:
    17
    Good day,

    First of all I want to say that i'm having the exact same issues with Asus 3.0.0.4.384.32799 firmware. ( did the test by reflashing it and restoring to factory default to test) so I don't know if that can be resolved or not within merlin firmware or not.

    So basically, I have an VOIP ATA connected on the LAN side registered with voip.ms sip provider.
    The issue is that when CTF (nat acceleration) is enabled, I can make and receive phone call but the remote phones can't hear me (but I can hear them). I reproduced that also with the echo test provided by voip.ms (dialing 4443) and using a softphone running on IOS from the wifi on that network (Acronis GroundWire)

    As soon as CTF is disabled, everything work as expected.
    With the help of the voip.ms tech team that's what we tested so far without success:

    -Sip passthrough enabled, enabled+nat helper, disabled

    -firewall disabled, enabled but allowing sip and rtp traffic such as :
    iptables -A INPUT -p udp -m udp --dport 5060:5080 -j ACCEPT
    iptables -A INPUT -p udp -m udp --dport 10000:20000 -j ACCEPT

    -putting the ATA in the DMZ

    -QOS is off

    -AiProtection is off


    From voip.ms perspective, after they analysed the trafic on their side, they said that somehow some audio packet coming from my router contained headers with my lan ip address instead of the wan ip (this is going above my network knowledge and that is definitely an issue with my router...) but basically that was a nat issue...

    I could disable CTF but at the cost of a major internet speed drop. With CTF on, I run on 900mbps down and 1100mbps up while going at 300mbps down and 200mbps up when CTF is off (sometime lower than that.)

    Any idea or suggestions ?
     
  2. JDB

    JDB Very Senior Member

    Joined:
    Aug 28, 2016
    Messages:
    624
    Having LAN IP’s in your packets is not unusual or unexpected.
    Your SIP provider should be able to handle that.
    I suspect with CTF on the Nat helper does not function.
    The solution will be to configure the Nat helper solution on the ATA - the simplest option is usually to configure a STUN server on it.
    If you SIP Provider is worth their salt (which sounds like they aren’t!) they should host a STUN server. Otherwise have a google for a public one.
    The ATA should just have a field you put the URL or IP of the server in.

    It is also highly unusual for the direction you have not working to be the issue, normally you would not hear the other party as they can’t get the RTP into your LAN from the WAN. So on that basis this may not be a ‘normal’ NAT issue.

    Source: Own my own telecoms consultancy :)


    Sent from my iPhone using Tapatalk
     
    Grisu and joe scian like this.
  3. Tlex

    Tlex Occasional Visitor

    Joined:
    Mar 7, 2017
    Messages:
    17
    Thanks,
    I'll give a try with google stun servers tonight.
    I was told also that this bug might be specific to Asus ac-rt5300...
     
  4. Robaye

    Robaye Occasional Visitor

    Joined:
    Dec 28, 2015
    Messages:
    18
    I have a AC68U, and I have had some recent inbound (to me) complaints. I also have Voip.ms, along with an old Cisco PAP2T.

    Some one way audio I cannot hear them, like you. One call voice mail picked up by my provider, when usually my phone voice mail answers. I was wondering if replacing ATA setup with IP phone/s might make some service quality difference. Maybe Yealink.

    Just rebooted the ATA and turned off CTF, as I could usea break from complaints. Glad I found your post. We'll see how it goes. Maybe ultimately will consider another low cost provider, such as Callcentric.

    Adaptive QOS
    fq_codel
    SIP Passthrough: Enable

    I have had some VoIP issues in the past, but somewhat recently seemed to have cropped up again. The cordless batteries on the handsets are pretty fresh.
     
    Last edited: Oct 22, 2018