1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

HDD spindown on R7800

Discussion in 'NETGEAR AC Wireless' started by DevilzSoul, Apr 5, 2019.

  1. DevilzSoul

    DevilzSoul New Around Here

    Joined:
    Mar 29, 2019
    Messages:
    7
    I have a 4tb WD External Elements HDD (bought brand new a month ago) attached to USB port on R7800. My firmware is the Stock Netgear V1.0.2.62

    My problem is that my HDD wont spindown and constantly make noise of read/write. I have looked through all the options of firmware but I cant seem to find anything that will allow me to put USB Device on standby or sleep mode.

    is there anything I can do to resolve this (short of buying a SSD) - any other firmware that has this option built in.. will appreciate some input
     
  2. Gallo

    Gallo Occasional Visitor

    Joined:
    Sep 11, 2018
    Messages:
    17
    hd-idle, sd-idle, sdparm, or hdparm. you're going to have to find a version thats compatible with your firmware or just install voxel's firmware, he's got it in his repo's
     
    Murtaza12 and kamoj like this.
  3. kamoj

    kamoj Senior Member

    Joined:
    May 12, 2017
    Messages:
    411
    The hd-idle is available in both Netgear and Voxel FW, so it's not a big thing to solve.

    Log in to the router and run this once (to activate spindown for all disks after 30 minutes of inactivity):
    Code:
    grep "hd-idle" /etc/rc.local || /bin/sed -i 's#^exit 0#/etc/init.d/hd-idle start \&\nexit 0#' /etc/rc.local
    /etc/init.d/hd-idle start
    
    If a shorter time, e.g. 10 minutes is preferred, run these commands once:
    Code:
    sed -i 's/30/10/g' /etc/config/hd-idle
    /etc/init.d/hd-idle restart
    
    That should be all!

     
    L&LD, Sizzlechest and Murtaza12 like this.