[Help] 5GHz radio dying on RT-AC66U_B1 running Merlin 384.18 firmware...

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

pwnedbygary

New Around Here
Hello,

I am running 384.18 on my RT-AC66U_B1 and I noticed that the 5G radio randomly turns off. I dont have any USB connected or anything special. The 5G connection was working one minute, now its off. I tried going to the CLI and running the 'radio toggle' command, but it only seems to toggle 2.4G and 5G stays 'disabled'. Do you have any idea why this might be?

Annotation 2020-07-28 193533.png


Annotation 2020-07-28 193626.png


Annotation 2020-07-28 194030.png
 

OzarkEdge

Part of the Furniture
I am running 384.18 on my RT-AC66U_B1 and I noticed that the 5G radio randomly turns off.
The one time I experienced similar with an RT-AC86U after a firmware flash, I reset, re-flashed the firmware, reset with Initialize from the webUI, configured from scratch, and never saw the issue again.

OE
 

pwnedbygary

New Around Here
Switch off the unit at the back, wait 10 seconds, depress reset button and then switch unit back on. Keep holding the reset button for 10-15 seconds. The Blue Power Light LED will blink slowly. Let go of the reset button and the Power light will continue to slowly blink. Let it blink for another 30 seconds before turning the unit off via the power button. Wait 10 seconds and then turn the unit back on. Wait for unit to restart and both 2G and 5G lights to illuminate.
I found these instructions in another thread here: https://www.snbforums.com/threads/issue-found-rt-ac66u-5-ghz-radio-not-working-on-380-65_4.38667/

They actually worked... I originally had issues after flashing firmware to the latest official. After that, i got the radio issue. I flashed to my current Merlin, and it solved it, but then power went out today for a second and caused it again. The steps above definitely fixed the issue where 5GHz radio was staying off permanently.
 

Artz

Occasional Visitor
Interestingly I had the same issue with ac88u. I got suddenly problems with 4 Ethernet ports not being available. Restart didn't help but unplugging the power and plugging again solved the issue with the ports. Then the 5GHz problems started. Exactly same as you have. The reboot solved it. Still working fine.
I wonder what could have caused the issues. Heat maybe.
 

jerry6

Very Senior Member
i'll say one thing that 5g runs HOT really hot maybe that's why it is shutting down ?
 

L&LD

Part of the Furniture
The 5GHz radio isn't showing a temperature (it says 'disabled'), the 78C is the CPU temperature which is okay.
 
Last edited:

Klueless

Very Senior Member
I doubt this will help but I was having a similar problem with 5 GHz for awhile. I tried a few things (reboot, reset, turn on and off radio, etc.) but the problem kept coming back.

Then I narrowed it down to a "bad client device" on 5 GHz that compromised the entire Asus 5 GHz service. It was a "range extender" that was overheating. I fixed it (cleaned off some dead stinkbugs that had fused themselves to the air vents) and I've been problem free ever since.
 
Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top