help configuring dnscrypt with adguard home

moretty

New Around Here
Hello everyone. First of all, sorry for the writing since I use the translator.
I have been trying for weeks to install dnscrypt along with adguard on my debian server both natively and in docker and now I decided I discovered that the best way is on my asus router with merlin, but in all of them the most I managed to do was make it work for a very short time and leaky dns.
I would like to ask you for help.
my main problem is that the adguard tells me that port 53 is already in use when I install it and when I put the .toml 127.0.0.1:53 in dnscrypt it gives me this error [FATAL] listen udp 127.0.0.1:53 bind: address already in use.
Thanks in advance
 
Last edited:

Zastoff

Very Senior Member
Hello everyone. First of all, sorry for the writing since I use the translator.
I have been trying for weeks to install dnscrypt along with adguard on my debian server both natively and in docker and now I decided I discovered that the best way is on my asus router with merlin, but in all of them the most I managed to do was make it work for a very short time and leaky dns.
I would like to ask you for help.
my main problem is that the adguard tells me that port 53 is already in use when I install it and when I put the .toml 127.0.0.1:53 in dnscrypt it gives me this error [FATAL] listen udp 127.0.0.1:53 bind: address already in use.
Thanks in advance
What router do you have? Firmware version? How are you installing DNSCrypt?
In AMTM: You have both DNSCrypt Installer and Adguard home installer
Think the AsusWRT-DNSCrypt installer uses 127.0.1.1:53
Recommend you try one of those installers if you have not done so already.
 

dave14305

Part of the Furniture
On Debian, you’d need to stop systemd-resolved listening on port 53.
Code:
sed -i 's/^#DNSStubListener=.*/DNSStubListener=no/g' /etc/systemd/resolved.conf
ln -sf /run/systemd/resolve/resolv.conf /etc/resolv.conf
systemctl restart systemd-resolved
 
Last edited:

moretty

New Around Here
Thank you very much for the help in the first place.
right now i was able to get it working on my debian server. the steps you take are these:
systemctl stop systemd-resolved
systemctl disable systemd-resolved
then edit nano /etc/systemd/resolved.conf and
[Solve]
DNS=127.0.0.1
#FallbackDNS=
#Domains=
#LLMNR=no
#MulticastDNS=no
#DNSSEC=no
#DNSOverTLS=no
#Cache=no
DNSStubListener=no
#ReadEtcHosts=yes

The only problem I have is that if I connect with wireguard through vpn in dnsleaks, it marks the isp dns instead of the anonymous ones.

That manually installing adguard and dnscrypt in debian, but the truth is that I would like to leave everything in my asus rt-ac68u.
Can you tell me how is the configuration in the router?
Thank you
 
Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top