help debugging miniupnpd - HTTP Connection closed unexpectedly

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

TheRavenster

Occasional Visitor
hi guys,

i was looking through my router log today (ASUS RT-AX86U on merlin 386.3_2) and noticed this constant message below, which seems to be coming from my nvidia shield (connected via LAN). I have disabled UPNP in the settings and want to know what it means.

Is the shield trying to connect to port 10170 and because i have UPNP set to disabled it doesn't work? thanks for the help.

Code:
Sep  1 19:54:37 miniupnpd[10170]: HTTP Connection from 192.168.1.236 closed unexpectedly
Sep  1 19:55:37 miniupnpd[10170]: HTTP Connection from 192.168.1.236 closed unexpectedly
Sep  1 19:56:22 miniupnpd[10170]: HTTP Connection from 192.168.1.236 closed unexpectedly
Sep  1 19:57:23 miniupnpd[10170]: HTTP Connection from 192.168.1.236 closed unexpectedly
Sep  1 19:58:08 miniupnpd[10170]: HTTP Connection from 192.168.1.236 closed unexpectedly
Sep  1 19:59:08 miniupnpd[10170]: HTTP Connection from 192.168.1.236 closed unexpectedly
Sep  1 20:00:23 miniupnpd[10170]: HTTP Connection from 192.168.1.236 closed unexpectedly
Sep  1 20:01:08 miniupnpd[10170]: HTTP Connection from 192.168.1.236 closed unexpectedly
Sep  1 20:03:08 miniupnpd[10170]: HTTP Connection from 192.168.1.236 closed unexpectedly
Sep  1 20:05:23 miniupnpd[10170]: HTTP Connection from 192.168.1.236 closed unexpectedly
 

ColinTaylor

Part of the Furniture
10170 is the process number of miniupnpd not the port number.

This clearly indicates that UPnP is running so double check it at WAN > Internet Connection > Enable UPnP.
 

TheRavenster

Occasional Visitor
thanks for the reply kind sir! i checked as you instructed and have the following UPNP disabled;

asus.png
 

TheRavenster

Occasional Visitor
ok, i logged back in and clicked on yes, then back to no, then apply and in the log it looks good so far;

Code:
Sep  1 21:08:59 miniupnpd[10170]: shutting down MiniUPnPd
 

ColinTaylor

Part of the Furniture
I think the Game/Open NAT option also enables UPnP.
 

TheRavenster

Occasional Visitor
you might be onto something here...i looked this morning and its back in the log. after searching about the pros and cons of turning off NAT, think i'll just leave it on and have to ignore the messages from the shield. oh well, thank you for the replies.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top