HELP! My network is behaving strangely....

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

DHLarson

Occasional Visitor
So, I have an AI Mesh network running 386.2_6 on the core AC86U and 2X AC68U nodes. Last night the network went down for an unknown reason with the core router in a loop cyclically shutting down the radios and the ethernet ports (both WAN and LAN ports) that I couldn't resolve without a serial connection which was beyond my capability. Deciding to give up since a down network does not make a happy home, I nuclear reset the core AC86U and reloaded the Merlin firmware (same release just to make sure it was clean.) Rebuilt just the basics (renamed wireless networks, assigned Comcast WAN static address range with DNS, user name, password) Router booted cleanly and failed to allow internet access by preventing DNS resolution showing timeouts on NSLOOKUP. As a result, NTP failed to synch, etc. Comcast address range has 5 assigned addresses using a 255.255.255.248 mask with a range of x.x.x.32 and a gateway address of x.x.x.38. Thinking the Comcast provided gateway that allows hybrid operation (routed NAT support for it's internal wireless and LAN ports) as well as routing to asserted assigned external static addresses was having issues, I assigned each of the 5 external IP addresses to a stand-alone PC and directly connected it to the LAN side of the Comcast gateway. Each of the addresses worked cleanly and whatsmyip showed the correct addresses externally. When I change the AC86U to DHCP, the AC86U gets assigned a 10.1.X.X address and works as expected (assuming you like double NATing and the like). I verified with Comcast tier 2 support that their gateway was working as expected and that there were no changes in configuration or firmware recently.

This obviously doesn't meet my intended use. I had a spare AC86U which I reloaded with the current ASUS factory load and nuclear reset process and got the same outcome. What am I forgetting to do that is causing this problem? I suspect that there was some kind of interaction that corrupted NVRAM or something else that forced the initial nuclear reset but the odds of two AC86U routers breaking identically on both Merlin and ASUS software seems remote. I'd appreciate any hints on troubleshooting, SMH config items that I have forgotten, etc. This is maddening....

BTW, the testing was done with the rest of the network isolated other than a single laptop dedicated to the effort. SSID names were changed to avoid contaminating the environment and the wired side of the network was unplugged...

Thanks!

Don
 

bbunge

Part of the Furniture
I have an AC86U on Comcast with the same static WAN IP address scheme as you. Am having no issues. But, I use Cloudflare Family DNS 1.1.1.3, 1.0.0.3. Also have two AC68U and one AC66U_B1 nodes. All on Asus factory firmware.
Edit: I noticed the RAM usage was going up so I added a thumb drive with a swap partition and set the router to reboot nightly. You mentioned a user and password for the WAN? Mine does not need that.
 
Last edited:

DHLarson

Occasional Visitor
Tried changing the DNS to google (8.8.8.8) with no improvement. There is some interaction between static addressing and DNS resolution that I'm just not getting. The user name and password I referred to was for the router itself, not the ISP.
 

DHLarson

Occasional Visitor
Still stuck. Static IP fails via AC86 routers running stock and Merlin 386.2_6 but same Comcast interface works with PC connected and static IP addresses. Ordered a ethernet tap adapter to see if I can do packet analysis to determine what's breaking between the AC86 and the Comcast Cisco based gateway.
 

DHLarson

Occasional Visitor
Closing this out. Stupidly used a -1 address for my static WAN address which proved to be non-responsive. Used a SharkTap between the ComCast gateway and WireShark to validate that the gateway was not responding to the AC86 DNS requests on the wire. Low and behold, when changing the static address to the first true addressable address, the magic begins. Sorry for posting my own stupidity but definitely can swear by the usefulness of a tap when you need it.
 

DHLarson

Occasional Visitor
One final note - as someone noted, there are strange things that can happen with AI Mesh configs. In order to clean up some random WiFi weirdness, I deleted my two Merlkin 386.2_6 AP nodes using the AI-Mesh tab on the main router, reset them to factory settings using the WPS method, replaced the Merlin firmware with the most current Asus factory firmware, re-associated them with ethernet backhaul and, wonder or wonders, the odd behavior seems to have gone away. Note - I'm not blaming the Merlin FW on the APs - I think it was just left overs from doing lots of stuff but why leave an uncertainty unresolved? I'm now rebuilding my VPN connections and awaiting Asus to reset my dynamic DNS name since this all started when I wanted to replace my primary router since it was acting "funny". Nuclear reset and rebuild by hand seems to be the right approach (although using the correct IP addresses doesn't hurt :) )

Thanks for your help and support. It definitely underlines how dependent we all are on the internet as part of our family infrastructures.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top