HELP: preventing Android device Ethernet connection to go down

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.


Occasional Visitor
Hello. I need some help with this.

For some unknown reason, my android box ethernet connection drops after e few minutes of using it. I already set a static IP on the device and my merlin Asus router, but this does not seem to help.
I wondered if there are any Tweaks and Hacks that I can do on the router to keep the connection alive?

Thank you very much.


Make WiFi Great Again

Regular Contributor
I recently bought a cheapo T95-S1 AndroidTV box on Amazon and I nearly went mad trying to fix that exact issue but I never did solve it. BTW I also had Wifi go down every few minutes and NOT automatically reconnect. I finally gave up and bought a nicer more expensive box (Xiaomi Mi Box S) and have not had any issues. In my case I should of paid the extra $25 for the nicer box in the first place. It doesnt have an ethernet port but for $6 i got a usb ethernet adapter and plugged it into the usb port and it works great.

so, failing everything else, try a usb to ethernet adapter if you cant get it going. but make sure it has the right chip. not all ethernet adapters are supported by all Android devices.


Regular Contributor
A couple of things to try; or try them both

Under Developer mode ( search on how to unlock it for your device), set it to always stay awake. Barring that under Battery & power saving. Tap Battery usage, Ignore optimizations, Then select the app(s) to ignore battery optimizations for. There are apps on Google Play that say they can fix it but all they are doing is setting their app up to ignore the battery optimization, you just need to keep the app running all the time. I just set all apps to ignore the optimizations. Note: the device may run warmer and if on battery, consume the battery a lot quicker. I've done both, just to be sure...

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!