Help troubleshooting WAN dropout

  • ATTENTION! As of November 1, 2020, you will not be able to reply to threads 6 months after the thread is opened. Threads will not be locked, so posts may still be edited by their authors.

brettule

Occasional Visitor
Hi there brains trust, I'm hoping you can help me get to the bottom of an issue plaguing me. I've been running an RT-AC68U for years with the same ISP and it's been rock solid. In the past 2 months I've started getting frequent dropouts under heavy bandwidth use, only under heavy use mind you. I believe the dopouts started after a 24 hour outage was restored, it may just be a coincidence but it feels like a smoking gun. I have 100mb fibre to my home with an NTD provided by the ISP and my RT-AC68U uses a PPPoE connection.

Symptom: When I push the bandwidth to max for 10mins or so the WAN drops and the RT-AC68U won't re-establish. I have to click the OFF/ON button in the Asus web interface to force a reconnect which it does immediately, otherwise the Asus won't retry.

Troubleshooting tried so far:
Firmware update to 384.19
Firmware downgrade back to 344.11 which is a year old and I was running fine back then.
Wipe and factory reset
Swapped the device with another RT-AC68U (I use it as a mesh wifi)
Called the ISP, they said that they see no outages on their side when I report a drop and they can continue to ping their NTD even when my router drops the WAN. They point the finger at my routing device or my firmware.
Connected a laptop direct to the NTD, established PPPoE and pushed the bandwidth for 30mins or so and it was stable. I probably needed to test longer and more frequently to get conclusive results but the household was bugging me to get the internet back for them.

Can you help me get to the bottom of this? Maybe some debug logs? Wireshark? I'm determined, with your help, to find the evidence and the culprit.

Thanks
 

brettule

Occasional Visitor
I checked the logs on the router and found the following when it went down today:
Code:
Sep  3 20:05:01 nat: apply redirect rules
Sep  3 20:05:07 WAN_Connection: WAN was exceptionally disconnected.
What does "exceptionally disconnected" mean?

Then when I manually stopped/started the WAN everything comes up like normal:
Code:
Sep  3 20:31:12 rc_service: httpd 3069:notify_rc restart_wan_if 0
Sep  3 20:31:14 pppd[9048]: Hangup (SIGHUP)
Sep  3 20:31:14 pppd[9048]: Terminating on signal 15
Sep  3 20:31:14 pppd[9048]: Connect time 6062.7 minutes.
Sep  3 20:31:14 pppd[9048]: Sent 2220186547 bytes, received 3355869403 bytes.
Sep  3 20:31:14 pppd[9048]: Connection terminated.
Sep  3 20:31:14 pppd[9048]: Sent PADT
Sep  3 20:31:15 dnsmasq[2652]: read etc hosts - 6 addresses
Sep  3 20:31:15 dnsmasq[2652]: read etc hosts.dnsmasq - 0 addresses
Sep  3 20:31:15 dnsmasq[2652]: using nameserver 8.8.4.4#53
Sep  3 20:31:15 dnsmasq[2652]: using nameserver 8.8.8.8#53
Sep  3 20:31:15 pppd[9048]: Exit.
Sep  3 20:31:18 rc_service: httpd 3069:notify_rc restart_wan_if 0

Sep  3 20:31:22 pppd[9102]: Plugin rp-pppoe.so loaded.
Sep  3 20:31:22 pppd[9102]: RP-PPPoE plugin version 3.11 compiled against pppd 2.4.7
Sep  3 20:31:22 pppd[9105]: pppd 2.4.7 started by admin, uid 0
Sep  3 20:31:22 pppd[9105]: PPP session is 42261 (0xa515)
Sep  3 20:31:22 pppd[9105]: Connected to f4:cf:e2:bd:28:d4 via interface eth0
Sep  3 20:31:22 pppd[9105]: Using interface ppp0
Sep  3 20:31:22 pppd[9105]: Connect: ppp0 <--> eth0
Sep  3 20:31:22 pppd[9105]: PAP authentication succeeded
 
Last edited:

brettule

Occasional Visitor
Doh. It's come back. Same error:
WAN_Connection: WAN was exceptionally disconnected.

Any ideas?
 

John Fitzgerald

Regular Contributor
Have you tried rebooting the modem via the pinhole method?
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top