Help with Pihole on RT-AX88U

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.


Regular Contributor
I'm having trouble getting Pihole to block adds on devices connected to my RT-AX88U.

My ASUS is running Merlin. The Pihole is running on an old Pi B plus model. I'm only using DNS on the Pihole. Not using DHCP.

The Pihole is showing URL requests and blocked sites but in reality when browsing the adds are still showing .

Mr router settings;

Under WAN settings:
Connect to DNS automatically = No
DNS server 1 =
DNS server 2 =

Under LAN DHCP Server:
DNS and WIN server setting DNS Server 1 and 2 = (IP of Pihole)
Advertise routers IP = no

Under LAN/DNS filtering
Enable filtering = on
Global filter mode = Router
Then included Pihole in client list with no filtering.

On the Pihole DNS settings page
Upstream DNS server set to cloudfare
Enabled use conditional forwarding with the IP address of the router.

What am I doing wrong? Many thanks in advance.


Part of the Furniture
Check your browsers to see if DoH is enabled. Remove the entry from LAN-DNS Server 2


Regular Contributor
Hi bbungei have removed from server 2.

On WAN prevent client from auto DoH is set to Auto. Is that correct?


Part of the Furniture
Hi bbungei have removed from server 2.

On WAN prevent client from auto DoH is set to Auto. Is that correct?
Yes. However, DoH can still be turned on. As for add blocking I use U Block Origin in the browser. My Pi-Hole uses Stubby for DoT/DNSSEC to Cloudflare Secure with malware on block lists. Pi-Hole will also block DoH from turning on.


Regular Contributor
It's strange, all my devices on my network are seeing adds. I just don't know what I'm doing wrong. Pihole shows all the queries but browsing the web I get adds every where.

I'm using the default Pihole blocklist.

Do you it's my router or the Pihole.what should my Pihole settings look like under settings/DNS?

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!