Help with wake on lan - WOL

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Begotten

Occasional Visitor
Hi, I've got a problem with the wake on lan feature.
I can't wake up my PC, with a static IP on my network, on my LAN with any apps available (iOS & Android) (I've tried about 20 different apps)
But, within the router RT-AC86U WOL interface I'm able to wake the PC.
And, yes, every device are just inside my lan.
Any ideas? Thanks for your help.
 
Last edited:

eibgrad

Very Senior Member
Are these portable iOS/Android devices connected w/ wifi inside the LAN, or w/ cellular outside the WAN?
 

GSpock

Senior Member
have you defined the IP you try to wake as permanent in the ARP table of the router ?
 

GSpock

Senior Member
You mean in the : LAN->DHCP Server-> Manually Assigned IP around the DHCP list (Max Limit : 128) section?
Yes, I did that.
No, I mean: via an SSH connection to the router issue the following command:
arp -s ip-addr mac-addr

then issue the following
arp -a

you will see your device that you want to wol tagged as PERM
 

Begotten

Occasional Visitor
Thanks, GSpock, I`ll give it a try.
I'm getting the PERM reponse.
But it doesn't work either.
The strangest thing is, like I said before, every apps (almost 10 different on iOS and 15 on Android) I've tried to wake my PC are not working, expect one Mocha WOL on my iOS tablet. That's what I found very strange.
Many thanks for your time, it's really appreciated.
 
Last edited:

GSpock

Senior Member
This is indeed very strange ; sometimes the arp table get flushed, so make sure it is PERM just before your test.
I am using the following on my android device, and it works OK, even when outside the LAN:

Wake On Lan from Sigma-Square UG

(make sure to use port 9 in any cases)
 

Begotten

Occasional Visitor
Hi,, I dont understand why it has to be so strange.
My PC with a statc IP adresse (192.168.1.4) diven by the router, the WOL option for this specific MAC address is enable on the router.
Every apps I tried on Android cant wake up my PC , (even the one suggested by GSpock).
Every apps I tried on my iOS tablet cant wake up my PC, execept the Mocha WOL.
I really don`t understand. There is always minimal configuration in all apps:
1- The MAC adress for my PC (that I double, triple checked)
2- The ip I want to wake, my PC with the static ip adress 192.168.1.4
3- and the `Magic packet` that I`m leaving to 9, Yes I checked on my Win PC that everything is enable for the WOL and to be sure the magic packet is on the 9 port.
4- What`s leaving me without word, is one and only one can wake up the PC.

Many thanks
 

GSpock

Senior Member
... indeed, a complex case.

What you would need to figured-out is what that Mocha applications does that the others do not .... Also, as last test, you mentioned that WOL via the router GUI works, that is fine. What about issuing the etherwake command at CLI via SSH ? does it work too ?
 
Last edited:

Begotten

Occasional Visitor
Many thanks for your help,
Yes it did work, but I had to make a more global command to get it work, ie : ether-wake -b -i br0 74:d4:35:xx:xx:xx
 

elorimer

Very Senior Member
Perhaps similarly your other applications were only sending to the specific IP address and not to the broadcast address, and that wasn't working?
 

Begotten

Occasional Visitor
Many thanks to all of you,
you where right,
with a broadcast to 192.168.1.255, and using the port 40000 on other apps (I don't know why this port and not 9, my WOL settings are with the port 9) I can wake up my PC,
Thanks guys
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top