Hi guys,need a help about stubby logging thru SSH

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

doublehd

Regular Contributor
How I can disable the stubby logging (stubby -l) ? my router's syslog full of those msgs..Thanks for it.
 

Attachments

  • Screenshot_2021-04-09 ASUS Wireless Router RT-AC88U - General Log.png
    Screenshot_2021-04-09 ASUS Wireless Router RT-AC88U - General Log.png
    379.4 KB · Views: 45

BreakingDad

Senior Member
Change log level on stubby

# uci set stubby.global.log_level='2'
# uci commit
# /etc/init.d/stubby restart
 

ColinTaylor

Part of the Furniture
Stubby should not be logging unless you enabled it.
Indeed.

From one of Dave's earlier posts:
To disable:
Bash:
nvram unset stubby_debug
service restart_stubby
Although I don't know why the output would end up in the syslog rather than its own log file. It looks like the OP has intentionally enabled logging but via a different method.
 
Last edited:

doublehd

Regular Contributor
Those don't look like asuswrt commands. They look like OpenWRT commands. Did you try them? Did it work?
so I should stay put ?
Indeed.

From one of Dave's earlier posts:

Although I don't know why the output would end up in the syslog rather than its own log file. It looks like the OP has intentionally enabled logging but via a different method.
argh,I was just key in "stubby -l" from SSH,and saw those msgs rolling from it should be.I then exited SSH.But it turns out those msgs found in the router's syslog...gosh.Thanks colin,will kick myself to fix it.
 

ColinTaylor

Part of the Furniture
so I should stay put ?

argh,I was just key in "stubby -l" from SSH,and saw those msgs rolling from it should be.I then exited SSH.But it turns out those msgs found in the router's syslog...gosh.Thanks colin,will kick myself to fix it.
Just reboot the router and they should stop, if they didn't do so when you logged out of SSH.
 

bbunge

Part of the Furniture
When you run stubby -l from the command line the output will go to the sys log. Ctrl + c will stop the logging. Any other means of restarting Stubby will stop logging.
 

doublehd

Regular Contributor
When you run stubby -l from the command line the output will go to the sys log. Ctrl + c will stop the logging. Any other means of restarting Stubby will stop logging.
I did pressed ctrl+c but no luck.It just seemed to be activated the logging on router lol.
 

BreakingDad

Senior Member
Those don't look like asuswrt commands. They look like OpenWRT commands. Did you try them? Did it work?
No, i did some googling for him, thought that would point him in the direction he needed to go. Apologies if it mislead.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top