High WAN performance and QOS

Preskitt.man

Regular Contributor
Have an WAN facing AC86U. Until early this month, I was paying for and receiving 100 Mbs (symmetrical). All was good. Then got a letter from ISP that they were raising my speed to 300 Mbs - no additional charge.
But, when I went to test this, Speedtest on my ethernet connected Dell 8930 showed I was still at 100 Mbs. Tried it at various times of the day - same results. Called my ISP, and they insisted they had enabled the higher speed. Trying power cycling the router and try again. Which I did, with the same results.
So, start grunging around, and based on another post, I turned off QOS. Problem solved. Speeds were up to about 340 Mbs.
But then I go to wondering, was QOS (and its lack of hardware acceleration) that big a drag on performance. I mean, I was getting 100 Mbs before and not even a fraction faster afterwards.
And then I saw it, QOS has setting to limit both the download and upload speed, and long ago, when I first set it up, I had those each set to 100 Mbs. So I turned QOS back on and bumped the 2 speed limits up to 400 Mbs, and I still up at 340 Mbs.
Not really sure that I even need QOS on with these speeds, but always feels good to solve a mysterious technical problem
 

dave14305

Part of the Furniture
Both upload AND download are 300 Mbps? I wouldn’t bother with QoS if I had 300 Mbps upload. If it’s really 300 down, 10 up, then you might want QoS for managing the 10 Up.
 

Preskitt.man

Regular Contributor
Yes, both up and down are 300 Mbs. Makes sense to turn off QOS. Had it on in part to ensure good VOIP around the house.
 

dave14305

Part of the Furniture
What I would really do, on second thought, is manually put an fq_codel qdisc on my wan and lan interface to ensure smaller packets get better treatment.
Code:
tc qdisc add dev eth0 root fq_codel quantum 300 limit 1000
tc qdisc add dev br0 root fq_codel quantum 300 limit 1000
 

Tech9

Part of the Furniture
Yes, both up and down are 300 Mbs.

Turn it off. @dave14305 is the QoS specialist. I have seen excellent results on AC86U router with Bandwidth Limiter only (270/270 in your case). It works really well, if you use your entire network as target, something like 192.168.50.1-200 (depending on your DHCP settings). Your router will do 350Mbps with NAT acceleration disabled, no performance penalty. NAT acceleration disabled also stops constant kernel error messages in logs, if you have IPv6 enabled for some reason. You have to log everything to see them. I personally don't like NAT hacks, they may cause more issues with VoIP.
 

Tech9

Part of the Furniture
Around here, that's like being the weird guy no one understands. :)
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!

Members online

Top