hosts.add

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Scott Kaforey

Occasional Visitor
Hello,

I am trying to add a few entries to the hosts file so that they can be used by my entire network.

I tried adding it to /jffs/config/hosts.add and restarting dnsmasq, but it did not seem to take effect. I verified by checking and my entry wasn't added to /etc / hosts.

Rebooting the router fixed the issue, but I'm wondering how I can get it to add all of my hosts to / etc/ hosts without editing that file directly. Is there another command to run, or service that I should be restarting?
 

dave14305

Part of the Furniture
service restart_dnsmasq should update the hosts file as well, assuming JFFS custom configs and scripts are enabled in the GUI. They must be if it worked on a reboot. Check your syslog for messages that include “Appending”.

Also, make sure there is NOT a /jffs/configs/hosts file present (without .add).
 
Last edited:

Scott Kaforey

Occasional Visitor
Ok I figured out my problem. I was typing the wrong command to restart the service, but didn't know it because apparently even typing service alskfjalksfj_flakjsflkjaf echo's done to the terminal, which made me think I typed it right.

Thanks Dave!
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top