How to discover the MAC address of blocked devices?

federgejzla

New Around Here
Hi!

This is my first time with an ASUS router (AX-11000). I use and like to use MAC address filtering (yes, I know what some may say, but that isn't the question - I have my own reasons for using this). With Netgear routers I was using in the past I was able to see the list of denied ("blocked") devices (and "allow" them) and their MAC addresses. They were written to the logs too. I need this because I need to add the MAC address of a new device to the MAC filter list and I can't always have alternate ways of obtaining it, say with some IoT devices I use.

I've dug through the router's administration UI all over, including logs, searched the web and the forums but have found nothing. I am sure that the answer is probably somewhere out there but this is particularly hard to find because there is a popular other question that uses the same keywords - how does one add a MAC address to the list and unblock the device ... but all of them assume that the MAC address is already known.

Can anyone help? Or is there simply no exposure of blocked MAC addresses in ASUS routers?

Thanks!
 

ColinTaylor

Part of the Furniture
I'm not sure I'm understanding your question, but go to Wireless > Wireless MAC Filter and choose the relevant band. Maybe that's what you're after.
 

federgejzla

New Around Here
That is the place to see the list of those already allowed and add more. I have many configured already - those I knew MAC addresses for. But I have some new devices that I have to add but can't find the MAC addresses for. They don't have this specified anywhere or exposed in their own UI (IoT).
 

ColinTaylor

Part of the Furniture
You should be able to see them at System Log > Wireless Log. They should also generate dnsmasq-dhcp log entries in System Log > General Log. Also Network Map > Client status/list.
 

HWDan

Occasional Visitor
or turn off the device, disable filtering, turn on and let the device connect, now you have it, add it and re-enable filtering.
 

ColinTaylor

Part of the Furniture
or turn off the device, disable filtering, turn on and let the device connect, now you have it, add it and re-enable filtering.
Ah, OK. Is this your problem @federgejzla - you are blocking all devices from connecting by default? If that's the case then you will probably have to do as @HWDan says.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top