How to let Devices see each other in Guest network?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

nikr

Regular Contributor
Hello,

I recently switched to Asus router and have two questions about Guest network. I am running asuswrt-merlin on ax86u

1. I see Guest network 1 gets its own DHCP range where as guest network 2 shares IP addresses from the main network DHCP pool. why? While its not an issue as long it works but, can it be changed so that it gets its own IP range?

2. I an using Guest network 2 for all my IOT devices. For this particular network I would devices to be able to see each other but not have access to intranet. Reason being it makes it easy to add new device to IOT network and also some of the devices need phone and device to be able to see each other for firmware update to work.
 

nikr

Regular Contributor
YazFi is exactly what I was looking for. Unfortunately it seems, once enabled, clients connected to guest network no longer shows up under Network Map -> client list. Is there a way to fix it?
 

eibgrad

Very Senior Member
YazFi is exactly what I was looking for. Unfortunately it seems, once enabled, clients connected to guest network no longer shows up under Network Map -> client list. Is there a way to fix it?

I don't use it, but it doesn't surprise me if that's the case. Once you resort to third-party scripting, you're necessarily working outside the GUI. And those kinds of niceties are often sacrificed.
 

New2This

Senior Member
If you look at the Wireless log. You can see your clients there, other than that. No other way to see them connected
 

GSpock

Senior Member
YazFi is exactly what I was looking for. Unfortunately it seems, once enabled, clients connected to guest network no longer shows up under Network Map -> client list. Is there a way to fix it?
I guess you should ask this directly to @Jack Yaz
 

CaptainSTX

Part of the Furniture
If you look at the Wireless log. You can see your clients there, other than that. No other way to see them connected

You can also see them in LOG under DHCP leases.
 

bennor

Regular Contributor
YazFi is exactly what I was looking for. Unfortunately it seems, once enabled, clients connected to guest network no longer shows up under Network Map -> client list. Is there a way to fix it?
See System Log > Wireless Log in the Asus-Merlin GUI Admiration interface.

Or issue the SSH command: cat /var/lib/misc/dnsmasq.leases

Any further YazFi questions should probably be put in the YazFi 4.x thread: https://www.snbforums.com/threads/yazfi-v4-x.70308/

And post 17 of the YazFi 4.x thread answered your question too. ;-)
 
Last edited:

Omni

New Around Here
Is the guest device isolation a new thing? I was running stock Asus firmware and two days ago updated. Prior to the Asus update I was using a wireless guest network for my google home and chromecast devices with my phone and laptops on the same network. I had no problem casting, accessing the printer etc. After the firmware update this stopped working. I thought Asus borked something so I switch to Merlin but it is the same. I can't setup the Google home anymore when connecting to a guest network, I get a message about AP isolation and turning it off.

I have read the replies above and will check out the YazFi, but as my first question asks - is the guest isolation a new thing? Why was it working for me before?

Thanks!
 

bennor

Regular Contributor
Is the guest device isolation a new thing?
The Asus and Asus-Merlin firmware has had the option to block Guest WiFi clients from accessing the intranet (local LAN) via the Access Internet setting in the Guest WiFi configuration. Further there is a general WiFi option buried in the Advanced Settings > Wireless > Professional tab called Set AP Isolated. Both of these these appear to be broad settings that affect all WiFi clients. This is how the embedded ? info popup describes each one in the Asus firmware:
Access Intranet
Allow guest to access intranet.

Set AP Isolated
When this feature is enabled, wireless clients or devices will not be able to communicate with each other. You may want to utilize this feature if you have many guests that frequent your wireless network.
It appears the difference with Merlin and the use of YazFi is one can leave the settings Access Intranet and Set AP Isolated at their default settings (not enabled), and access the YazFi configuration to enable the Client Isolation setting. This setting applies Client Isolation only on the specific YazFi Guest Network. In other words a more granular approach that doesn't affect non Guest WiFi clients and or that doesn't affect the other YazFi Guest WiFi networks if used.
Client isolation
Should Guest Network radio prevent clients from talking to each other?
Edit to add: Some IoT device features won't work if one enabled the YazFi Client Isolation option or if one enables the Asus or Asus-Merlin Set AP Isolated option. Some IoT devices need to be able to communicate with each other for certain features to work. For example the Amazon Echo combine speakers feature won't work for me if I enable any sort of client isolation so the Echo devices cannot communicate with each other on the local (WiFi) network.
 
Last edited:

Omni

New Around Here
Thanks bennor for your reply!

I indeed use the Guest network so that I can isolate the clients from my intranet, but I don't wish to isolate them from each other. I found the setting for AP Isolation in the professional tab and it was, and is, set to 'no'. I also just tested moving my phone and Google home to the regular wifi network (not a guest network) and the setup worked fine, they can talk to each other and the setup can complete.

What I see from this is that when connected to the main wifi network the clients are not isolated from each other. When the clients are on a guest network I have the problem that they are isolated from each other - even though the setting in the professional tab is set to no.

Is this the expected behaviour? Is there any other way I can remove the isolation that is happening between clients on a guest network?

Thanks again!
 

bennor

Regular Contributor
Thanks bennor for your reply!

I indeed use the Guest network so that I can isolate the clients from my intranet, but I don't wish to isolate them from each other. I found the setting for AP Isolation in the professional tab and it was, and is, set to 'no'. I also just tested moving my phone and Google home to the regular wifi network (not a guest network) and the setup worked fine, they can talk to each other and the setup can complete.

What I see from this is that when connected to the main wifi network the clients are not isolated from each other. When the clients are on a guest network I have the problem that they are isolated from each other - even though the setting in the professional tab is set to no.

Is this the expected behaviour? Is there any other way I can remove the isolation that is happening between clients on a guest network?

Thanks again!
One obvious troubleshooting step, if you haven't done so already, is to do a hard reset on the Asus router, could be something got wonky if one upgraded the firmware in the past.

Are all the guest wifi devices on the same Guest Network? In other words all on the same 2.4Ghz or 5Ghz single network? Or are they spread across multiple guest networks?

Are you using the AIMesh feature on the Asus router?

Another troubleshooting step is if one is using Guest Network #1 for all their guest WiFi devices. Try using Guest Network #2 (or #3) instead for all guest WiFi devices. Apparently the Asus firmware/code may use (if I understand past discussions here) Guest WiFi #1 for the Mesh network connections.
 

Hawk

Senior Member
I also remember reading somewhere that Asus has hard-coded isolation in guest networks. Which would explain why main works and not on guest.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top