What's new

How to set arp ip static wake on lan/wan

CerB

Occasional Visitor
Hi there.
Using a Asus ac68u with johns fork on it.
I have a laptop connected that has plex server installed and also works as a minecraft server.

my problem is when trying to wake on lan or wake on wan, after sometime, i cant wake the laptop from either lan or wan. it works fine when the first minuts after the laptop sleeps.

Latop has static ip, and it has Manually Assigned IP from mac adress on the router.

i have forwarded ports 7 and 9 to play with.

In router interface i can wake the laptop up anytime i want, even after 8 hours. but not sending magic packet from either phone, tablet or laptop.

i have been reading a little about arp table to set the ip static so router wont clear cache.

but i cant figure out how to do it, i have some guides like this one

"What I have done now is the following:

1) Opened telnet on a different computer connected to the same router. My primary computer was disconnected from the router at this point. A note on this: I guess that I could have used the primary computer by changing the ip-address to something other than 10.0.0.1 prior to telneting. I ran into the problem where the router updates the arp automatically before I got around to typing in the addarp-command. This way the entry stays tagged as dynamic, and I won't be able to change it to static. Changing the ip to let's say 10.0.0.2 would probably let me work on adding the 10.0.0.1 as static without the router messing it up.
2) "telnet 10.0.0.138" (My router)
3) Put in username/password
4) "ip arplist" (This gives me all the devices in the list, I saw that all devices had been tagged as DYNAMIC. Now I wanted to change it to STATIC)
5) "ip arpdelete intf=LocalNetwork ip 10.0.0.1 hwaddr=xx:xx:xx:xx:xx:xx" (where the x's are the mac adress of my computer)
6) "ip arpadd intf=LocalNetwork ip 10.0.0.1 hwaddr=xx:xx:xx:xx:xx:xx"
7) Now when I list the arplist using "ip arplist" my computer is tagged as STATIC.


but i am not sure if this will work,

is there any newb guide to to this ? step by step guide ?
 

CerB

Occasional Visitor
Just for info for anyone els who might encounter this problem. i made i work doing this.

1. Enable telnet from router interface. Administration > System > Enable Telnet (Yes), Apply.
2. From windows command prompt, type the following,
telnet xxx.xxx.xxx.xxx <Enter> press the enter key, don't type Enter.

where xxx.xxx.xxx.xxx is the ip address of your router, most likely on a home router might be something like 192.168.1.1 or similar.

Enter your username for router when prompt comes up.
Enter your password for router when prompt comes up.

3. Type the following after logon to router via telnet.
arp -s xxx.xxx.xxx.xxx yy:yy:yy:yy:yy:yy <Enter>

Where xxx.xxx.xxx.xxx is the STATIC ip address of your network card, and
yy:yy:yy:yy:yy:yy is the MAC address of your network card.

NOTICE, the ip address numbers are separated by periods ".", and the mac address numbers are separated by colons ":", with a space in between the two.

To see if it was done correctly, type ARP from telnet prompt, it should show your computer ip address and mac address with PERM in the line, meaning permanent.
However, if you reboot your router, you will still have to enter this again, as it erases the arp table when you reboot.
At the telnet prompt, if all looks good, then type,
Exit <Enter>
Then exit command prompt.


I know i have to do it again on router reboot, but thats fine for now. it takes 1 min to do.
 

Martineau

Part of the Furniture
arp -s xxx.xxx.xxx.xxx yy:yy:yy:yy:yy:yy

I know i have to do it again on router reboot, but thats fine for now. it takes 1 min to do.
Place the arp command in services-start
 

CerB

Occasional Visitor
Seems it dosent work as hoped, if i let the laptop sleep for say, 1 hour i can still wake via lan/wan, but it seems to loose the arp setting sometime after that. I came home from work and i had been sleeping for almost 2 hours, i could not wake, not before i had telnet the arp command again.


what am i doing wrong ?
 

CerB

Occasional Visitor
been looking at that page before, must admit its a bit over my head, cant figure out first from last where to start or end.
 

Steffe

Regular Contributor
First you enable the jffs partition correctly (https://github.com/RMerl/asuswrt-merlin/wiki/Jffs). Should, however, be enabled in >.50 by default
Then ssh into you router and follow these commands:
mkdir /jffs/scripts/

echo "/usr/bin/logger -t \"($(basename $0))\" $$ \"Saving static WOL .....\"" >> /jffs/scripts/services-start
echo "sh /jffs/scripts/wan-wol.sh&" >> /jffs/scripts/services-start
echo "#!/bin/sh" >> /jffs/scripts/wan-wol.sh
echo "#purpose is to make a static route to nas server, so that i can be put online by WAN wol" >> /jffs/scripts/wan-wol.sh
echo "arp -s 192.168.2.x xx:xx:xx:xx:xx:xx" >> /jffs/scripts/wan-wol.sh
chmod a+rx /jffs/scripts/*

Reboot rooter. Wait a couple of minutes.

Type arp and see if it says
Device (192.168.2.x) at XX:XX:XX:XX:X:XX [ether] PERM on br0

On your device.


I havn't tested the commands here, but I assume that you are familiar with linux, and thus can type the information into the files manually as well.

Anyways, wake on lan normally works without static arp entry. So I would investigate whether you have sleep enable on the device http://www.groovypost.com/howto/enable-wake-on-lan-windows-10/ (win 10)
 

CerB

Occasional Visitor
wow thanks alot.

one thing, "Then ssh into you router" thats via putty right ? not strong at all in linux
 

RMerlin

Asuswrt-Merlin dev
One thing to keep in mind: if you use an additional switch on your LAN, some of them have green features that can interfere with WOL.
 

CerB

Occasional Visitor
No problem then, only a router after a modem, then the clients connects to ac68u. Laptop as plex / minecraft server, 1 nas and rest I wireless phones and tablets.

Sendt fra min Nexus 5 med Tapatalk
 

Steffe

Regular Contributor
wow thanks alot.

one thing, "Then ssh into you router" thats via putty right ? not strong at all in linux
Yes. Don't you use that for telnet as well? I would think that telnet works as well. I havn't worked with that personally though...
 

CerB

Occasional Visitor
Yes i did use putty for telnet, first time ever, so glad it worked. Thank you all for your help.

I hope others in the future can use this thread as guidance.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top