Huawei USB 3G dongle on AC88U = online vs. on AX88U = offline because of DHCP

amplatfus

Senior Member
Dear community,

I tried to solve this issue from some time.

What is happening. I am trying to use a Huawei USB 3G to connect to the interent, but anything I have tried I got same error only on AX88U: Your ISP's DHCP does not function properly.
On AC88U tha connection is working without any issue.
So: same 3G dongle, same SIM, on AC88U is working, on AX88U, the error is unchanged, no matter I have tried.

I captured from AX88U below rows from syslog:
Code:
Sep 17 170837 wan finish adding multi routes
Sep 17 170839 rc_service wanduck 1114 notify_rc restart_wan_if 1
Sep 17 170849 dnsmasq 4947 read etc hosts 6 addresses
Sep 17 170909 WAN_Connection ISPs DHCP did not function properly.
My testing enviroment:
1) AC88U: Merlin Firmware Version: 384.19 (and on all 384 branch tried);
2) AX88U: Merlin Firmware Version: 3384.19, with same input as profile: APN, user, pass.
3) Windows 10
4) Android 9 Pie, Llineage OS

I tried:
1) to re-flash firmware, clean with reinitialisation, format jffs, 3 restarts in 15 minutes, on clean, without any other customisation, on clean, same result;
2) checked in the USB from back side is working, but same error received;
3) to connect a Windows 10 to the internet using this USB 3G Dongle and it worked;
4) to connect a Android phone with the same SIM, on the same USB port and it worked, no promlem;
5) tried as single WAN, dual WAN, primary, seccondary, load balance.

Could you please help me to find the root cause?
Or what should I try next, before replacing the dongle :)

Edit1: there are few moments, right after reboot when the led from the USB dongle light up like is AX88U is connected on mobile network, but only for few seconds.

Thank very much in advance,
amplatfus
 
Last edited:

amplatfus

Senior Member
Hi,

Short update. In the meantime I have found this thread:

Inspired by this, I am trying to enter IP for DNS automatically, because I saw that while the Secondary WAN was active in the Network Map page I discovered some diffrences.
I exported the wan1 nvram variables from both (AC88U - whas connected, AX88U - not connected):

Code:
AX88U Secondary Huawei 3G USB Dongle offline
root-AX88U:/tmp/home/root# nvram show | grep ^wan1 | grep dns | sort
wan1_dns1_x=
wan1_dns2_x=
wan1_dns=
wan1_dnsenable_x=1


AC88U (same test) but online
root-AC88U:/tmp/home/root# nvram show | grep ^wan1 | grep dns | sort
wan1_dns1_x=
wan1_dns2_x=
wan1_dns=46.97.158.169 46.97.158.74
wan1_dnsenable_x=1
I hope this would be a step further.
Please share here if you have any kind of idea what is happening, or what should I try next to solve it.

Thank you very much,
amplatfus
 
Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top