HUAWEI Y7 phone can't send media via WhatsApp with RT-AC86U

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

lousybyte

New Around Here
I have a Huawey Y7 in a household among 5 other phones and is the only device that has this issue. All messages sent/received and all received media is working fine in WhatsApp but if I try to send a picture or video, or upload backups, then it just hangs on uploading forever.

At first I thought it's some DNS issue (even tho no other device has problems), but changing it to all kind of servers didn't fix it. Same with changing the DNS related settings like DoH, DNS Rebind or DNSSEC.

Then I thought maybe it's some WiFi issue, so I tried using a cheap router I had around to test in extender mode via WiFi and then also via ethernet cable connected to the Asus, but that didn't solve the issue either.

As soon as I disabled the Asus router completely and plugged the ISP cable straight into the cheap one, all the media started uploading in WhatsApp, so the Asus router is blocking it somehow it seems.
One thing I noticed, it started working fine when reconnected back to the Asus router as well for a while, but then started having issues again after a few hours. The behavior is really similar to a cached DNS or something related, but no other device has the same issue and no matter the DNS settings.

I tried reinstalling WhatsApp but was hanging on phone SMS confirmation sending as well, had to use mobile data for that. Also cleared the WhatsApp data and cache before and after.
No AIProtect, AIMesh or any other related extra features are enabled.
I've rebooted the router almost after every setting change as well.
Firewall disabled makes no change either.

Using the latest 386.1_2 firmware but the issue was also present in 384.19.


I'm out of ideas on what to try anymore, any help greatly appreciated.
 

lousybyte

New Around Here
Apparently the issue was due to the WAN MTU size, was set to my ISP 1400, after I changed it back to the default 1500 everything got fixed.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top