I don't understand this error

SmallNetGuy

Regular Contributor
Hi, you all amazing and always super helpful forum members. I truly hope this message finds you all well and in great health.

I was away for quite some time now, but I am back. Got a pretty great deal on Asus RT-AX86U, so I grabbed it. Everything is pretty smooth sailing, except I've noticed these lines started appearing in my system log file quite often. I have 7 WiFi clients on my home network (2 x Android phones, 2 x Windows 11 Pro PC, 1 x Samsung Roku TV, 1 x iPhone and 1 x MacBook Pro). My internet connection is nothing amazingly and super duper fast, but it's more than I need at this point. It's cable internet through Shaw, called Fibre+ 150.

Note that not all of those 7 WiFi devices are on all the time. In most cases, it's only 3 or 4 of them. I am getting these errors a lot lately, and I can't pin point where are they coming from. I am suspecting it's my daughter's MacBook Pro (2013), because I see those errors disappear for some time when I turn that laptop's connection off.

I've also noticed YouTube videos are loading slow sometimes, and sometimes they even chug (that loading animation when it's loading the video into the buffer). Not sure if there is any connection between this and these System Log messages:

Apr 7 20:34:37 acsd: acs_candidate_score_intf(1133): eth7: intf check failed for chanspec: 0xe832 (36/160)
Apr 7 20:34:37 acsd: acs_candidate_score_bgnoise(1602): eth7: bgnoise check failed for chanspec: 0xe832 (36/160)
Apr 7 20:34:37 acsd: acs_candidate_score_txop(1860): eth7: txop check failed for chanspec: 0xe832 (36/160)
Apr 7 20:34:37 acsd: acs_candidate_score_intf(1133): eth7: intf check failed for chanspec: 0xe932 (40/160)
Apr 7 20:34:37 acsd: acs_candidate_score_bgnoise(1602): eth7: bgnoise check failed for chanspec: 0xe932 (40/160)
Apr 7 20:34:37 acsd: acs_candidate_score_txop(1860): eth7: txop check failed for chanspec: 0xe932 (40/160)
Apr 7 20:34:37 acsd: acs_candidate_score_intf(1133): eth7: intf check failed for chanspec: 0xea32 (44/160)
Apr 7 20:34:37 acsd: acs_candidate_score_bgnoise(1602): eth7: bgnoise check failed for chanspec: 0xea32 (44/160)
Apr 7 20:34:37 acsd: acs_candidate_score_txop(1860): eth7: txop check failed for chanspec: 0xea32 (44/160)
Apr 7 20:34:37 acsd: acs_candidate_score_intf(1133): eth7: intf check failed for chanspec: 0xeb32 (48/160)
Apr 7 20:34:37 acsd: acs_candidate_score_bgnoise(1602): eth7: bgnoise check failed for chanspec: 0xeb32 (48/160)
Apr 7 20:34:37 acsd: acs_candidate_score_txop(1860): eth7: txop check failed for chanspec: 0xeb32 (48/160)

Any help would be greatly appreciated!
Kind Regards
 

Tech Junky

Very Senior Member
If I'm looking at this correctly you're setup for 160mhz channels and the router doesn't like it.

It's scanning from channel 36-48 on 5Ghz and is having issues getting a clear 160mhz lock. Try switching to 80mhz and see if things stabilize or move the router towards the core of your house and away from the windows. Another option would be reducing the power setting.
 

SmallNetGuy

Regular Contributor
If I'm looking at this correctly you're setup for 160mhz channels and the router doesn't like it.

It's scanning from channel 36-48 on 5Ghz and is having issues getting a clear 160mhz lock. Try switching to 80mhz and see if things stabilize or move the router towards the core of your house and away from the windows. Another option would be reducing the power setting.
Thank you so much for your kind reply, greatly appreciated! Router is exactly at the center of our house, and it's one level detached house, all users are on that same floor. It's one of those bi-levels houses, new development (completed two months ago).

Sorry for my ignorance (or stupidity), but how do I switch to 80MHz again? Thank you so much in advance!

EDIT: sorry, it's right in front of my nose, under Wireless tab. So basically I just need to disable that option called "Enable 160 MHz"?
 

bbunge

Part of the Furniture
Thank you so much for your kind reply, greatly appreciated! Router is exactly at the center of our house, and it's one level detached house, all users are on that same floor. It's one of those bi-levels houses, new development (completed two months ago).

Sorry for my ignorance (or stupidity), but how do I switch to 80MHz again? Thank you so much in advance!

EDIT: sorry, it's right in front of my nose, under Wireless tab. So basically I just need to disable that option called "Enable 160 MHz"?
Actually, do not disable the 160 MHz but use SmartConnect, 5 GHz at 20, 40, 80, 160 MHz and the 2.4 Ghz at 20 MHz. Both bands on Auto Channel. Let the router choose what works best for the bandwidth and channel.
 

ColinTaylor

Part of the Furniture
This error has nothing to do with 160MHz per se. If you look at the error message it is coming from the auto-channel selection daemon.

This process periodically scans all the available channels to determine whether it should move to a better one (the "candidate score"). As I reported in other threads there seems to a be bug in that process where sometimes it's unable to obtain the data from the wireless interface. This means that it will just stay on the current channel rather than switching.

As the wireless code is provided by Broadcom as binary blobs there's nothing that can be done to fix it other wait for an updated driver from Broadcom. In the meantime you can either ignore the messages or turn off "Auto" Channel and variable Bandwidth and select a fixed channel and fixed bandwidth instead.
 

Tech Junky

Very Senior Member
@ColinTaylor

Well in the land of hostapd this ACS scanning would interrupt 5G signals and push you to 2.4G in the meantime. If the 5G SSID is offline due to the recalc then you're going to notice the switchover / degraded experience every few minutes when it attempts to find a good channel.

I set my AP on a clear channel and avoid this non-sense completely.

This "smart connect" is just pushing you to the lowest bandwidth and ramping up for consistent downloads. Most of the time is spent in the 80mhz arena anyway for most client devices.

When you get into the nitty gritty of how WIFI sets up for AP mode it gets interesting. I did a DIY AP with a AC2600 card inside a Linux box and played around with some of the options to wring the most possible bandwidth out of it and there are some quirks to different chipsets.

In this case the 160 setting is causing the ACS recalc to happen because 160 doesn't provide non-DFS channels across 100% of the requested space. Switching to 80mhz contains the channels to lower or upper allocations and excludes the DFS range. Moving the location away from DFS sources can allow for the 160mhz option to work w/o constant recalc / surveys to be performed causing interruptions to the devices on the network.
 

ColinTaylor

Part of the Furniture
@ColinTaylor

Well in the land of hostapd this ACS scanning would interrupt 5G signals and push you to 2.4G in the meantime. If the 5G SSID is offline due to the recalc then you're going to notice the switchover / degraded experience every few minutes when it attempts to find a good channel.

I set my AP on a clear channel and avoid this non-sense completely.

This "smart connect" is just pushing you to the lowest bandwidth and ramping up for consistent downloads. Most of the time is spent in the 80mhz arena anyway for most client devices.
This is not how the WiFi works on the RT-AX86U. The router does use hostapd, but acsd is a separate process that runs independently. The Broadcom driver can collect enough information (noise, interference, etc.) about the other channels without disrupting the connected clients (I've tested this thoroughly).

In this case the 160 setting is causing the ACS recalc to happen because 160 doesn't provide non-DFS channels across 100% of the requested space. Switching to 80mhz contains the channels to lower or upper allocations and excludes the DFS range. Moving the location away from DFS sources can allow for the 160mhz option to work w/o constant recalc / surveys to be performed causing interruptions to the devices on the network.
That's not what's happening. As I explained in my previous post it's a bug. As you can see in the output below the WiFi driver knows which channels are valid and which aren't. When it's working properly acsd is just reading the channel statistics from the driver.
Code:
ACSD Candidate Scores for next Channel Switch:
Channel (Chspec) Use DFS      BSS     busy  interf.  itf_adj      fcs  txpower  bgnoise    TOTAL      CNS      ADJ     TXOP      DFS     RBSS    RTXOP
36/160 (0xe832)  dfs      100        0        4        9        0      170        3     1041      -81        0      750        5        0        0
40/160 (0xe932)  dfs      100        0        4        0        0      170        3     1032      -81        0      750        5        0        0
44/160 (0xea32)  dfs      100        0        4       13        0      170        3     1045      -81        0      750        5        0        0
48/160 (0xeb32)  dfs      100        0        4       13        0      170        3     1045      -81        0      750        5        0        0
52/160 (0xec32)  dfs       10        0        4        5        0      170        3      947      -81        0      750        5        0        0
56/160 (0xed32)  dfs       10        0        4        5        0      170        3      947      -81        0      750        5        0        0
60/160 (0xee32)  dfs       10        0        4        3        0      170        3      945      -81        0      750        5        0        0
64/160 (0xef32)  dfs       10        0        4        3        0      170        3      945      -81        0      750        5        0        0
100/160 (0xe872)  dfs  Invalid:DFS
104/160 (0xe972)  dfs  Invalid:DFS
108/160 (0xea72)  dfs  Invalid:DFS
112/160 (0xeb72)  dfs  Invalid:DFS
116/160 (0xec72)  dfs  Invalid:DFS
120/160 (0xed72)  dfs  Invalid:DFS
124/160 (0xee72)  dfs  Invalid:DFS
128/160 (0xef72)  dfs  Invalid:DFS
100/80 (0xe06a)  dfs        0        0        0        1        0      170        5      231      -85        0       50        5        0        0
104/80 (0xe16a)  dfs        0        0        0        1        0      170        5      231      -85        0       50        5        0        0
108/80 (0xe26a)  dfs        0        0        0        1        0      170        5      231      -85        0       50        5        0        0
112/80 (0xe36a)  dfs        0        0        0        1        0      170        5      231      -85        0       50        5        0        0
116/80 (0xe07a)  dfs  Invalid:DFS
120/80 (0xe17a)  dfs  Invalid:DFS
124/80 (0xe27a)  dfs  Invalid:DFS
128/80 (0xe37a)  dfs  Invalid:DFS
 
Last edited:

SmallNetGuy

Regular Contributor
Thank you guys, thanks to everybody in this thread. Yes, as I mentioned I am not as proficient as any of you are, understand the basics, but this is really way above my knowledge.

Anyway, funny thing is... after I disabled 160MHz at Tech Junky's recommendation, I have not seen that error since. The only time I saw anything mentioning eth7 in my System Log file, was this...

Apr 8 12:53:10 hostapd: eth7: STA 0a:52:6d:7f:b1:df IEEE 802.11: associated
Apr 8 12:53:10 hostapd: eth7: STA 0a:52:6d:7f:b1:df RADIUS: starting accounting session D190B7B96E482249
Apr 8 12:53:10 hostapd: eth7: STA 0a:52:6d:7f:b1:df WPA: pairwise key handshake completed (RSN)

Thank you all so much for chiming in. I don't understand good 70% of what you talked about (embarrassing to admit), but it's so interesting to read and even just trying to learn. Sure, I could simply ignore the error if it happens again, no problems about that... I was just wondering if it's causing some additional problems I am not aware of, or don't see them at the moment.

That thing with YouTube also puzzles me. I've had EdgeRouter X SFP, followed couple of great tutorials on how to set it up for my specific connection back then (last year, was on Virgin Mobile Fiber connection), and I have never had such a smooth experience with YouTube or any video streaming service for that matter. I literally have never seen that loading animation, buffering or anything like that. I am pretty sure I might not have configured everything properly on my new ASUS RT-AX86U, but it worries me that I see so much YT loading/buffering. Even simple skipping to a different time point in a video, takes couple of good seconds to start playing that video (5-10 seconds sometimes). Not sure if there are any specific settings I should be playing with in order to remedy this behavior? I am also attaching a screenshot of my speed test. It used to be around 170-180 Mbps for Download and always 15-16 Mbps for Upload. I've noticed last couple of days when I measure, it's closer to 80-90 Mbps for the Download (not always testing through my router's interface, sometimes I go to dedicated Speed Test sites). My computer where I do these tests is also in the same room with my router, basically just few feet away.

ST.jpg
 

ColinTaylor

Part of the Furniture
Your download speed shouldn't suddenly drop from 117Mbps to 95Mbps. Check that router's WAN interface speed (Tools - System Information > Network > Ethernet Ports) hasn't changed from 1Gb to 100Mb.
 

SmallNetGuy

Regular Contributor
Actually, do not disable the 160 MHz but use SmartConnect, 5 GHz at 20, 40, 80, 160 MHz and the 2.4 Ghz at 20 MHz. Both bands on Auto Channel. Let the router choose what works best for the bandwidth and channel.
Thank you so much! I actually just did this couple of minutes ago, and this is what I saw in my router's System Log file regarding the eth7:

Apr 8 15:16:50 acsd: eth7: Selecting 5g band ACS policy
Apr 8 15:16:50 kernel: sched: RT throttling activated
Apr 8 15:16:56 roamast: ROAMING Start...
Apr 8 15:16:56 wlceventd: wlceventd_proc_event(505): eth6: Auth 52:7B:AD:73:C9:EF, status: Successful (0)
Apr 8 15:16:56 hostapd: eth6: STA 52:7b:ad:73:c9:ef IEEE 802.11: associated
Apr 8 15:16:56 wlceventd: wlceventd_proc_event(534): eth6: Assoc 52:7B:AD:73:C9:EF, status: Successful (0)
Apr 8 15:16:56 hostapd: eth6: STA 52:7b:ad:73:c9:ef RADIUS: starting accounting session A7C874FDAA6AC2E2
Apr 8 15:16:56 hostapd: eth6: STA 52:7b:ad:73:c9:ef WPA: pairwise key handshake completed (RSN)
Apr 8 15:16:57 dnsmasq-dhcp[6272]: DHCPDISCOVER(br0) 52:7b:ad:73:c9:ef
Apr 8 15:16:57 dnsmasq-dhcp[6272]: DHCPOFFER(br0) 192.168.50.235 52:7b:ad:73:c9:ef
Apr 8 15:16:57 acsd: eth7: selected channel spec: 0xee32 (60/160)
Apr 8 15:16:57 acsd: eth7: Adjusted channel spec: 0xee32 (60/160)
Apr 8 15:16:57 acsd: eth7: selected channel spec: 0xee32 (60/160)
Apr 8 15:16:57 acsd: acs_set_chspec: 0xee32 (60/160) for reason APCS_INIT
Apr 8 15:16:57 wlceventd: wlceventd_proc_event(505): eth6: Auth 8C:85:90:A0:3D:69, status: Successful (0)
Apr 8 15:16:57 wlceventd: wlceventd_proc_event(534): eth6: Assoc 8C:85:90:A0:3D:69, status: Successful (0)
 

SmallNetGuy

Regular Contributor
Your download speed shouldn't suddenly drop from 117Mbps to 95Mbps. Check that router's WAN interface speed (Tools - System Information > Network > Ethernet Ports) hasn't changed from 1Gb to 100Mb.
Thank you so much for spending your precious time trying to help Colin, greatly appreciated! It actually dropped from 177 Mbps to around 90 Mbps. It indeed looks like WAN's link is 100 Mbps :oops:

This is the screenshot from that page:

scr.jpg
 

ColinTaylor

Part of the Furniture
Thank you so much for spending your precious time trying to help Colin, greatly appreciated! It looks like it's 100 Mbps indeed :oops:
Try replacing the Ethernet cable between the Asus and your EdgeRouter. If it's still stuck a 100Mbps see if there's an option in the EdgeRouter to set its interface speed.
 

SmallNetGuy

Regular Contributor
Try replacing the Ethernet cable between the Asus and your EdgeRouter. If it's still stuck a 100Mbps see if there's an option in the EdgeRouter to set its interface speed.
Oh, I don't have EdgeRouter anymore. That was last year when I was on Virgin Mobile Fibre in Ontario. Now I live in Southern Alberta and I am with Shaw cable internet. Box they provided me with is HITRON CGNM-2250, and it's put into bridge mode just so I can connect my Asus RT-AX86U. I use that box as a modem only, not the router. As a router I use AX86U.

Unfortunately I am not sure if I can access the interface of that modem, or that has to be done by Shaw (requiring me to get on call with them).
 

SmallNetGuy

Regular Contributor
Ah, OK. Try changing the Ethernet cable.
Oh my, oh my!!! When someone knows their stuff, they know their stuff! You guys are all amazing! I replaced the cable, even though the other one was CAT6, one of those flat profile cables. I simply replaced it with the one that came with AX86U inside the box, and I believe that one is CAT5e. WAN switched instantly to 1Gbps (see screenshot attached please), and my internet speed went back to "normal", usual 180 Mbps!! Was it my cable only? What changed? I used exactly the same cable since I've connected my AX86U a month and a half ago.

Thank you so much!


scr2.jpg


ST2.jpg
 

SmallNetGuy

Regular Contributor
Just one more question... is there anything specific I'd have to do with WAN MTU? Right now it's sitting at 1500.
 

ColinTaylor

Part of the Furniture
Was it my cable only? What changed? I used exactly the same cable since I've connected my AX86U a month and a half ago.
It's not uncommon for cables to go bad or intermittent, particularly if they're the thin type. They can have breaks in the wires or connectors so that even a slight movement can cause a problem. Plugs and sockets can become loose over time or the metal contacts can become dirty, corroded or less "springy". I regard Ethernet patch cables as "consumables".

Just one more question... is there anything specific I'd have to do with WAN MTU? Right now it's sitting at 1500.
That should be fine unless your ISP specifically instructs you to change it.
 

SmallNetGuy

Regular Contributor
Great to know about MTU. Yes, cables do go bad from time to time, and this one I loved it because it's flat, classified as CAT 6. Maybe my wife did something when vacuuming, who knows. Anyway, now I'm on the original one from the Asus box, CAT 5e (that should be fine, correct?).

My YouTube streaming is as snappy as it used to be. I click on some spot in time throughout the video, and video starts playing almost instantly.

System Log file and the mention of eth7 (the one that was giving me all those errors), looks like this now:

Apr 8 16:16:46 hostapd: eth7: STA a0:f3:c1:27:44:92 WPA: group key handshake completed (RSN)
Apr 8 16:16:46 hostapd: eth7: STA ac:12:03:9c:5e:05 WPA: group key handshake completed (RSN)
Apr 8 16:16:46 hostapd: eth7: STA 8c:85:90:a0:3d:69 WPA: group key handshake completed (RSN)
Apr 8 16:16:46 hostapd: eth6: STA 52:7b:ad:73:c9:ef WPA: group key handshake completed (RSN)
Apr 8 16:16:47 hostapd: eth7: STA 50:3d:c6:a8:bd:e1 WPA: group key handshake completed (RSN)
Apr 8 16:16:47 hostapd: eth7: STA 7e:97:ae:47:63:13 WPA: group key handshake completed (RSN)

Is it recommended to use QoS (and what's the best configuration I should go with?) or not? I know it heavily depends on the situation, specific requirements of the household, etc. I play online (Xbox Series X) from time to time, nothing major, simply relaxing after work for an hour or so. My 15 year old likes to watch her fashion/makeup YT videos, we watch Netflix (only in the evenings), my wife runs online shop (last 7+ years), and that's pretty much all we do when it comes to internet activities.

Once again, you guys are a life savers! I know it's easy to say "...it's not my cable, it's brand new one...", but I've been burned couple of times in the past, and I know they could go bad in an instant. Sometimes the solution is right in front of us, but we all need someone to open our eyes from time to time :) Thank you for that!
 

ColinTaylor

Part of the Furniture
Looking good. :)

Yes, Cat5e is all that's needed. The other syslog messages you mentioned in posts #11 and #19 are just normal messages.

As for QoS that's a whole new can of worms. Personally I would try using it without QoS for the time being. With QoS it's very easy to make things worse if you're not careful. If you experience problems then you can enable it. I'm sure there are some people here more knowledgeable than me that can give you some pointers.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top