In some dire need of assistance (AX86U)

ColinTaylor

Part of the Furniture
Just to clarify what I meant above. The problem is not with the radar/channel change as such. AFAICT it's because the router has moved from the only channel group in my area that isn't being used by nearby AP's to one that is heavily used.

This can be demonstrated if I deliberately select a non-DFS channel that's occupied by other AP's and restart the router. After the router comes back up it immediately goes into the 5GHz crash/reinit loop always showing the same error, "wlc_check_assert_type HAMMERING: reinit_reason 2".

I did briefly try the latest stock firmware and noticed that Asus have turned off all those WiFi debugging messages now (or maybe they changed the log level). I didn't do enough debugging before I reinstalled Merlin to determine whether the problem is fixed or whether you just don't see the messages anymore.

As like you I can work around the problem for the most part, I'll wait until Merlin merges in the current Asus code and do more testing then. Hopefully Asus has fixed the problem rather than just hiding the messages. The problem with just hiding the crashes is that every time the AP is reinitialised it causes a momentary pause in WiFi traffic of about 400 to 600 ms. I imagine that might be quite annoying for latency sensitive applications.
 
Last edited:

drojo

New Around Here
I have also written to Asus exposing this problem and they do not seem to have much intention of solving it. So I had no choice but to find the solution myself since I did all the possible tests and nothing. The only way to make it work has been to put a WIFI repeater and connect all the google homes to that access point. They continue to use the DHCP server of my ASUS AX68U but they connect to the repeater's Wi-Fi and they have completely finished the problems and have not disconnected again, so apart from solving the problem it is clear that the problem is in the driver, firmware or some of the WIFI of the ASUS AX. I do not know if they can fix it in ASUS or it is simply some hardware that is impossible to fix by firmware. So here I leave you the solution that if it works even if it is just to buy another small wifi repeater but that works perfectly!
 

fallinnn

Occasional Visitor
Ah so this is why my wifi6 phone kept falling back to mobile connection completely random and my desktop wifi6 160MHz very often randomly seemed to drop the connection even tho the wifi symbol was always on? My nest audio didn't seem to care though... My other devices (tv and more) that's using the 2.4ghz never had any stability issues. Well that's disappointing! I just returned my ax88u thinking it was the issue and was about to buy the ax86u... Guess I'll have to stick to my ac5300 a little while longer.
 
Last edited:

DarkKnight75

Senior Member
Had similar issues with 2 ax86u routers...5ghz set to 160ghz and router crashed and rebooted after a day or so...lost wifi temporarily so went back to my ac86u.
 

fallinnn

Occasional Visitor
I returned the AX88u that I had the problems i tried to describe above with. Bought an AX86u a month later and have been using it every day since. No problems. No clue if they have fixed it or not, but I was CLEARLY experiencing it on the 88, and my connection is 100% rock solid on this 86u. Using 160mhz on both my work laptop (work from home) and my gaming desktop (wifi6). Highly recommend the ax86u. Maybe some devices are faulty? I don't know. I noticed a huge difference
 

shadowfiber

Regular Contributor
Hi All,

So far after 386.4 update, no issues. Perhaps the change to DHCP solved it?

Code:
  - CHANGED: Switched to Asus's own dhcp hostname support.

             Existing dhcp_hostnames entries will be

             converted on first boot.

Will post if there is any change or it breaks again.
 

Unisoft

Regular Contributor
If the devices report getting disconnected from wifi (as reported on the Wireless Log page), then I doubt it's related to DHCP, more likely to be a wireless-specific problem. A client with DHCP issues should still be able to stay connected to the wireless AP.

In the wifi settings, make sure you also disable Airtime Fairness - I've seen a lot of devices having problems with that, especially on the 2.4 GHz band. Can't recall if Asus finally changed that to be disabled by default (we've had talks about it in the past).

Also, stick to WPA2/Personal. Some devices seem to have issues if authentication on the router is set to both WPA2/WPA3.

Clients reporting a static IP is normal when that client gets an IP from somewhere else - it's the router's way of saying this client does not have a DHCP lease from the router itself. It has no way of saying if it's from a separate DHCP server, or from a static configuration.
I had issues with Huawei devices working one minute and then not the next or Access denied issues with 3 AX86U.

To cure, I already had Airtime Fairness and Universal beamforming set to OFF.
I have WIFI6 AX so didn't want to disable it and I set it as "20/40/80/160"
  • Beacon Size 300, DTIM 3 - safe value, but 400 can often work with even better battery life.
  • For 2.4 WIFI, I use 20mhz only (40 is not really used on 2.4 as device has to support it too. Can cause some devices not to connect if set).
  • Wifi channels are best left to looking at a WIFI analyser app result to decide or inbuilt WIFI Survey. Auto is OK where not too many access points but can cause issues where there are lots due to swapping around of channels.
  • I use WPA2/WPA3 as the connection type. Not has any issue with this setting.
  • Protected Management Frames = Capable (on 5ghz I know my devices support it, so I set Required)
  • For RING devices to work reliably at one location with lots of access points in the neighbourhood, I set Enable WMM No-Acknowledgement as Disabled. This seems to boost connection speed and video recording.
  • Enable WMM APSD as Enable
  • TX Bursting as No
  • Enable WMM as Yes
  • Optimize AMPDU aggregation as Disable
  • Multi-User MIMO on 5ghz as Enable (Disable if you continue to have connection issues as most small homes would not benefit as intended for larger spaces).
  • This setting cured the Huawei issue: OFDMA/802.11ax MU-MIMO as DL OFDMA Only
  • 802.11ax/ac Beamforming on 5ghz as Enable
Those are some of my settings for 2.4ghz and 5ghz except where stated.

I have a rock solid WIFI now with over gigabit speeds on WiFi AX devices. Two locations are greenfield with no other access points around and one has many around.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top