intermittent issues with RT-AX88u dual wan and Load Balance

Pierre Nakashian

Regular Contributor
I've been trying out DUAL WAN Load balance, it seems the cable modem is picky, I got it working by using the mac clone feature.
when my cable modem was provisioned they used the cable modem mac address, and at the time it was connected
to the ASUS router WAN port. I used that WAN port (eth0) mac address in the WAN Type Ethernet LAN mac Address (LAN port 4).
At the command line ifconfig shows WAN eth0, has the exact same address as LAN port 4 eth1.
Either the command line is not showing true mac address for eth1, or something else is going on with DHCP
when cable modem is connected to that port specifically.
the ATT modem also behaved strangely when it was connected to LAN port 4, the DMZ setting on the ATT modem didn't work
eth1 was assigned a private address not a public IP. But at least ATT modem worked on LAN port 4.
ATT DMZ setting you assign which mac address gets the public ip address, so it must have seen another mac address from LAN port 4.

a few times I rebooted the RT-AX88u router then I ssh into the router, I could ping an internet site by hostname inside the router, yet no LAN device in my home had internet access.
both eth0 (WAN) and eth1 (LAN) had ip address from their respective services,
the routes looked normal (route -n).
a quick fix was to kill the udhcpc process with the interface eth1 (LAN port 4)
and relaunch from command line with the same switches i've seen other times.
I did take a snapshot of nvram before and after I got the internet working.

when internet was down the following nvram settings stuck out
aae_sip_connected=0
nat_state=1

after internet worked normally
aae_sip_connected=1
nat_state=2

does someone know what those nvram settings mean?
also question on how can the ASUS router have internet access, yet no devices in my home network
had internet access but they could connect to the ASUS router like my notebook?

worst case I can write a script run from cron, that can check nat_state, if its not 2, to kill the udhcpc process for the eth1 interface
then I don't have to baby sit load balance.
 
Last edited:

Tech9

Part of the Furniture
Dual WAN is not working on Asus routers and we have this:

 

Pierre Nakashian

Regular Contributor
initially I did setup my DUAL WAN in failover mode when DUAL WAN Load balance mode LAN port 4 could not even get an ip address from the ISP. At the time even the failover mode had issues for me on boot LAN port 4 also didn't have ip address from ISP, but killing udhcpc and relaunching it only then got an ip address assignment. playing with script was pointless when failover also wouldn't work without help. I think My isp wasn't allowing any traffic to the ASUS router because it didn't recognize the mac address on the LAN port.

In my opinion there is some blame to the ISP modems why Load Balance or Failover mode don't work.

ASUS router in the past with my old ATT modem (without DUAL WAN) also had at times was plagued with it had internet access internally but no connected device in my home could see the internet. I'm trying to pick up a few more diagnostic tricks here that i can script myself.
 
Last edited:

Tech9

Part of the Furniture
In my opinion there is some blame to the ISP modems why Load Balance or Failover mode don't work.

It doesn't work as expected with any modems. It never worked for years.
 

Pierre Nakashian

Regular Contributor
The issue I described is not unique to load balance. How can the router have internet access, but LAN devices do not?
I had a similar issue intermittently with an older ATT gigabit modem model connected to the ASUS router without DUAL WAN.

Only thing I can think of is Natting wasn't successful during startup in both cases but for different reasons. So inside the ASUS router interface eth0 has a public IP, Natting isn't needed for traffic to go to the internet for traffic originating inside the ASUS router. The rest of LAN devices without the NAT the packets with private address would reach the ISP without being translated so they would be dropped somewhere before reaching their destination.

The ping test in the DUAL WAN Failover script would not work here, if internet is down for LAN devices only, because for the ASUS router it is not and ping test would still be successful.

looking through the source code nat_state=1 means NAT_STATE_REDIRECT
nat_state=2 means NAT_STATE_NORMAL.

I can check for this condition via `nvram get nat_state` if its not 2 internet to the LAN devices is down.

Only remaining question, how do I restart the NAT service without rebooting the ASUS router?
service start_nat?? service start_nat_rules??

I did try service stop_nat and service stop_nat_rules the value from nvram get nat_state didn't change from 2.
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top