Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Internet only works when routed through VPN

Discussion in 'Asuswrt-Merlin' started by vx117, Dec 7, 2017.

  1. vx117

    vx117 New Around Here

    Joined:
    Dec 7, 2017
    Messages:
    1
    I have a strange issue affecting my Asus RT-AC68U running 380.68_4. I cannot connect to the internet with any devices (whether it's wired or wireless). They will ONLY connect to the internet properly (can browse) if the I route that device's traffic through the OpenVPN Client tunnel on the router.
    Otherwise, I cannot browse the internet with the browser with any other devices not routed through the router's VPN connection.
    I tried tracert and ping on my desktop (not routed through VPN) and they seem to be working fine, I can ping and tracert www.google.com properly. I have tried turning the firewall on and off, changing the DHCP Server settings to point to 8.8.8.8, but nothing seems to work. It has happened before on an earlier firmware build, but it disappeared when I upgraded to the current build and now, the problem has resurfaced.

    Thanks in advance and please let me know if more info is needed.
     
  2. Twiglets

    Twiglets Occasional Visitor

    Joined:
    Aug 15, 2014
    Messages:
    20
    I would check your DNS setup or any routes you may have set in the Routing Table on the router itself.
    I have seen this when there has been a 'misconfiguration' of the DNS and/or the 'Routing Table', normal DNS lookup's do not work.
    When the OpenVPN Client is running it will reconfigure your DNS & Routing, hence why it works.
    (See the 'Accept DNS Configuration' option in the OpenVPN Client setup screen.)

    Also note that if you do not 'flush' the DNS cache on the Windows Desktop Machine, you may get answers for DNS lookup straight out of your local 'DNS Resolver Cache' and not from the router ---> DNS.
    Run ipconfig /flushdns from a cmd prompt, then try your tests again (without OpenVPN running).
    If you do not get valid results it points to a 'misconfiguration' somewhere.
     

Share This Page