Internet status: Disconnected bug in 386.5


Occasional Visitor
Since using 386.5 I notice a bug.

Now an then the network connection shows

Internet status:

But internet connection is still working.

I figured out that this problems occurs when using VPN together with Connect to DNS Server automatically set to 'NO'.

Tested with NordVPN and Cybershark with different different dns-servers manually set. Even is you set the DNS servers of the ISP manually, this problem occurs.
As soon as you set Connect to DNS Server automatically to 'YES', the problem is gone.


New Around Here
Evening folks,

I can confirm the very same behaviour described above with my AC86U/386.5.

The fact that there aren't hordes of people in here saying 386.5 is broken suggests me and Dimmie are doing something wrong, but I haven't been able to work out what it is. I've been flashing these Merlin firmwares for about three years now with never a hitch. This version I've flashed twice, the second time carefully following this procedure...

The gui initially looks ok, but soon intermittently reports "Disconnected". If it was only the gui telling lies I wouldn't care, but for me the WAN side does drop out occasionally and I have to reboot. As Dimmie says, setting WAN DNS to automatic fixes the problem (although I didn't run it like this for very long), but with VPNs configured that's no solution.

Two questions:

Is there any practical difference between resetting factory defaults from the gui and by power-cycling with the WPS button pressed on?

Are there any pitfalls in reverting to older firmware versions?

Many thanks.


Occasional Visitor
I did a full reset. First form GUI and then manually reconfigure the VPN. Second time with WPS and then manually reconfigure the VPN. But in both cases the problem is still there.
So a factory reset does not solve this bug/problem.


Occasional Visitor
I also tried this solution but does not work:


New Around Here
My AC86U on 386.5 also shows the WAN is disconnected on the GUI, but I haven't noticed any performance problems yet.


Occasional Visitor
My RT-AX88u also shows internet disconnected with 386.5, but the internet connection is OK on clients. I have Mullvad OpenVPN installed. The setting noted earlier for autostart of the VPN makes no difference to the (false) internet disconnected status. There is nothing in the log about a problem.


New Around Here
Somewhat related problems with my AC86U on 386.5: The router could not get an DHCP address from my ISP, shows "Disconnected", and I can't get online with that version of the firmware.
I'm using "DNS over TLS", and "Connect to DNS server automatically" to "No".

Downgrading to 386.4 or 386.3.2 fixes the problem

Edit: Same problem with 386.5.1
Changing "Connect to DNS Server automatically" to "Yes", and/or disabling "DNS-over-TLS" has no effect. So maybe not related to the above problems? Oh well, back to 386.3.2 for me
Last edited:


Part of the Furniture
This sure sounds like it's related to the WAN connectivity check performed by the router. Every 15 secs, it will issue a query to to verify the WAN is connected. And if anything interferes w/ that process (e.g., a DNS server that refuses to resolve it), it's going to report as Disconnected. As my DNS monitoring utility has shown, DNS configuration on the router can get rather complex. And things don't always work as expected. Might be interesting to see what the utility reports in this regard under different configurations.

P.S. When the router reports Disconnected, what happens if you try to do an nslookup on from an ssh session on the router? Does it succeed or fail?
Last edited:


Occasional Visitor
It looks like that I figured out a solution/workaround...

Go to administration > system
At 'Network Monitoring' enable 'dns query'
Set 'Resolve Hostname' to
Set 'Resolved IP Addresses' to
Click 'Apply' on the bottom of the screen
At 'Network Monitoring' disable 'dns query'
Click 'Apply' on the bottom of the screen
Tick 'reboot' on top of the screen

Strange but true... Just enable 'dns query' and disable it again exactly like the above steps.. and the problem is gone... which is strange because according to GUI settings, all settings are turned back as they were before... so no changes should be expected in the behaviour of showing 'disconnected'...


New Around Here
I've concluded that I've got a different problem with my RT-AC86U, than what's talked about here, although I use many of the same settings, for example "Connect to DNS Server automatically"="No", "Network Monitoring"="DNS query", and are using VPN. Mine shows "Disconnected" as well, but that's because I can't get an DHCP IP from my ISP, with any of the 386.5.x versions. Guess I'll try a factory reset, when I am allowed the service time, and start a separate thread if that doesn't help.


Regular Contributor
I have AX88U, never had issue like that. But things that I noticed in logs is that there are constant connects and reconnects on few of my lan ports. And I even try to put fix IPs but no changes. Cable is ok I tried to change it, still same.


Regular Contributor
I had the same red light and "Disconnected" issue. For me, it happens when I use NordVPN's SmartDNS service. I fixed it by setting "Wan: Use local caching DNS server as system resolver (default: No)" to yes.

Screen Shot 2022-03-28 at 14.54.05.png

P.S. The Internet worked fine the entire time, it just claimed not to be connected.


Part of the Furniture
there are constant connects and reconnects on few of my lan ports

Normal when Ethernet connected devices go into power save or sleep mode. Unrelated to the subject of this thread.


Very Senior Member
Are we "supposed" to have Network Monitoring on now with this firmware?

I don't have ping or dns query on, and mine shows as connected.

Haven't messed with it as it appears to be all ok?


Occasional Visitor
I had the same problem reasently, probably not tge same source of the problem. It was due to day light saving last sunday on my old ac66u none b1. (Old firmware)

Sins the firmware dont have the most reasent info about it the npt went out of sync.
I changed it to correct day and time and so on and after pressing apply internet jumpt ON again.


Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!