Internet Status - disconnected

grahamgo

New Around Here
RT-AX88U Merlin Firmware 386.5.2 This has been running for weeks. But today whilst making a small change noticed that in Network Map, the internet status is shown as Disconnected. However, the router is working perfectly well. But the error is niggling. Everything seems fine. I do have another unused router model RT-AC2900. I exported the RT-AX88U settings into the RT-AC2900. I ran that and found it has the exact same problem (internet state disconnected). So, I installed standard Asus firmware 3.0.0.4.386_48260. Low and behold the Internet is shown as connected. See the two attachments. So the problem appears to be with the Merlin firmware 386.5.2

My question is there something that I can do to fix the problem? I do not really want to go through a complete factory reset - reinstall everything to find that the problem still exists. Is there anything else less destructive that I can do to fix this error?
 

Attachments

  • worksnot.JPG
    worksnot.JPG
    86.9 KB · Views: 23
  • works.JPG
    works.JPG
    90 KB · Views: 26

eibgrad

Part of the Furniture
You can always make a backup of nvram and jffs before you do the factory reset. If the problem persists, just restore them and you're back where you started.
 

grahamgo

New Around Here
You can always make a backup of nvram and jffs before you do the factory reset. If the problem persists, just restore them and you're back where you started.
Hi, I trawled this forum and the internet looking for the same error and couldn't find anything. Actually, I am tempted to do your suggestion on the spare, unused RT-AC2900.
 

ColinTaylor

Part of the Furniture
This is a common issue that has been discussed endlessly. Ignore it.

I exported the RT-AX88U settings into the RT-AC2900.
Don't ever do this. The settings file is not transferable to another router, even if it's the same model.
 

grahamgo

New Around Here
This is a common issue that has been discussed endlessly. Ignore it.


Don't ever do this. The settings file is not transferable to another router, even if it's the same model.
Point taken. I, therefore, tried the following. Hard reset - installed Merlin v386.1.0 dated 30-1-2021 this does not work - it displays "Internet status - Your ISP's DCHP does not function properly". Then did another hard reset and installed Merlin v384.14.2 dated 1-1-2020, this runs, and also displays the same error message. I then install ASUS dd-wrt, this works fine. All this on my spare router. Also, the router supplied by T-mobile ISP works fine. My main router RT-AX88u continues to work fine, despite showing Internet status - Disconnected I'm afraid to touch this router until I get the spare one working correctly.

I am at a bit of a loss on how to fix this, I would appreciate any ideas. I'm wondering if there is something in NVRAM or somewhere that is surviving between hard resets causing the issue.
 

ColinTaylor

Part of the Furniture
Point taken. I, therefore, tried the following. Hard reset - installed Merlin v386.1.0 dated 30-1-2021 this does not work - it displays "Internet status - Your ISP's DCHP does not function properly". Then did another hard reset and installed Merlin v384.14.2 dated 1-1-2020, this runs, and also displays the same error message. I then install ASUS dd-wrt, this works fine. All this on my spare router. Also, the router supplied by T-mobile ISP works fine. My main router RT-AX88u continues to work fine, despite showing Internet status - Disconnected I'm afraid to touch this router until I get the spare one working correctly.

I am at a bit of a loss on how to fix this, I would appreciate any ideas. I'm wondering if there is something in NVRAM or somewhere that is surviving between hard resets causing the issue.
You are describing two different issues. In your OP you said the status showed Disconnected but everything still worked "perfectly well". This is typically caused by a recent upstream change made by Asus and subsequently picked up by Merlin. It can usually be fixed by doing this: https://www.snbforums.com/threads/a...nnection-but-internet-works.78388/post-756752

The problem that you're now describing, "Your ISP's DCHP does not function properly" is different and has been discussed for years. I'm not aware of a solution for that as it seems to be specific to certain ISP's equipment.
 

grahamgo

New Around Here
You are describing two different issues. In your OP you said the status showed Disconnected but everything still worked "perfectly well". This is typically caused by a recent upstream change made by Asus and subsequently picked up by Merlin. It can usually be fixed by doing this: https://www.snbforums.com/threads/a...nnection-but-internet-works.78388/post-756752

The problem that you're now describing, "Your ISP's DCHP does not function properly" is different and has been discussed for years. I'm not aware of a solution for that as it seems to be specific to certain ISP's equipment.
Hello, yes sorry. I confused things by writing about two different routers. The primary one is the RT-AX88U which is working perfectly well but showing internet disconnected. I didn't want to risk playing with this one. So used another spare one an RT-AC2900 which did replicate the problem, but eventually showed the "Your ISP's DCHP does not function properly". Which definitely convinced me to leave the RT-AX88U alone :)

Thank you very much for the fix, I applied it and the problem is solved. With great relief, because I use some functions of Merlin which made using Asus dd-wrt a difficult option.

My regret is that I did not find the fix myself. I did search this forum for quite some time but just didn't find it. Thank you very much!
 

Attachments

  • works.JPG
    works.JPG
    62.6 KB · Views: 17

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top