1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

iPhone connects to wifi, no internet. Android works fine..

Discussion in 'Asuswrt-Merlin' started by apollo18, Oct 16, 2019.

  1. apollo18

    apollo18 Occasional Visitor

    Joined:
    Jun 20, 2019
    Messages:
    28
    hey guys i have a network with an ac68u as the main router and a bunch of asus/other routers in access point mode. this setup has worked fine for the past 6 months, never had any problems, and iove never had issues,

    a couple days ago i think we had a power surge or soemthing so my router 87u died, and i didnt wanna lose internet connection so i quickly hooked up my backup 68u as the main router.



    however now im coming accross an issue where iphone users cannot get internet connection however there wifi is connected. it only happens with some iphones, my iphone works fine but a bunch of other people are having these problems, however every android works fine. i also noticed if i bring the troubled iphone to the main router and connect to that netowrk it works fine but if I connect to an access point it will say "no internet connection". after restarting the routers and the phone i can usually get it connected but this seems to be an ongoing problem.



    what do u guys recommend i do? there must be some setting that is making this happen in my asus wrt merlin


    tldr: iphone users connect but no internet connection, android works fine!
     
  2. sentinelvdx

    sentinelvdx Very Senior Member

    Joined:
    Sep 23, 2014
    Messages:
    537
    Location:
    Buenos Aires - Argentina
    Dumb question, but you have already installed latest RMerlin and did a hard reset after right?

    Sent from S.G. S9 Plus Duos using Tapatalk
     
  3. L&LD

    L&LD Part of the Furniture

    Joined:
    Dec 9, 2013
    Messages:
    9,749
    Your post isn't really clear what happened? You're using an RT-AC68U for the last few months but your RT-AC87U died? :)

    Have you tried forgetting the network on the affected iPhones? Have you tried on the phones a network reset?

    Can you try a new/never before used/ SSID and see if the problem still persists?
     
  4. apollo18

    apollo18 Occasional Visitor

    Joined:
    Jun 20, 2019
    Messages:
    28

    hmm, so i ended up turning my modem into a gateway and disconnecting the ac68u, and going thru there.
    so rn my connection is:

    modem as gateway ----> switch -----> access point ------> daisy changed to more access points (have like 8 of em)


    im still having the same issue, some devices connect and get internet and some just get the 'no internet access"

    i assume it has to be my wifi network or my switch? just makes no sense to me.

    probably have to recreate the networks on every access point?


    this used to work perfectly fine for more then 1 year but for some reason been getitng mad problems in the past couple weeks