What's new

IPv6 config on Asus RT-AX86U with Google Fiber

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

choleric

Regular Contributor
I'm using an Asus RT-AX86U with Google Fiber. I'd like to enable IPv6 but don't understand the options nor the potential security implications of them. Which one should be used, Native, Static IPv6, or Passthrough? Asus' document is of no help, and Google says "You're on your own".
 
I'd like to enable IPv6 but don't understand the options nor the potential security implications of them.

Keep it at default Disabled unless you have a specific reason to enable IPv6.
 
Alright, works for me.

For a minute I thought there was an upside to me to enable IPv6.

Guess I'll wait for it to become a dire issue, at which time they'd better handle their shirt more systematically.

Thanks.
 
Oh, how cute. I said "s" followed by "hit", and the site automatically replaced it with "shirt". Adorable. Truly. I'm going to adopt a puppy and squeeze it.
 
I'm going to adopt a puppy and squeeze it.

The cat on the picture not soft enough or CAT6 fast?

1709763341074.png


And if you see this cat around - RUN for your life!

1709763671231.png
 
I'm using an Asus RT-AX86U with Google Fiber. I'd like to enable IPv6 but don't understand the options nor the potential security implications of them. Which one should be used, Native, Static IPv6, or Passthrough? Asus' document is of no help, and Google says "You're on your own".

With Google Fiber - use the passthru option - it'll use DHCPv6, and give a /56 subnet...

HTH - and for those that say "don't do IPv6" - well most of your devices are already doing it, link-local style..

With Google Fiber, IPv6 will give better peering on dual-stack networks through their CDN - better peering, better performance...
 
OK, so with the "passthrough" option, are there security implications? Please remember you're talking to a drunken imbecile.
 
I'm only an imbecile when I'm drunken, which is much too frequently lately (working a factory [production!] job to satisfy mama's insurance needs), and, just so happens, presently...
 
While we're on the subject, has anybody else "in earshot" ever been told "you've got too much knowledge and experience for the position for which you've applied"? I'm in a kind of tailspin over that...
 
While we're on the subject, has anybody else "in earshot" ever been told "you've got too much knowledge and experience for the position for which you've applied"? I'm in a kind of tailspin over that...
Yeah, I've been told I was overqualified. Not in a very long time, though.

I enabled IPv6 using the "Passthrough" settings, but my Windows 11 PC and my Android 10 phone both failed every IPv6 test I tried, even though I could ping IPv6 IP addresses from the router. Tried all the usual dumb stuff ("Did you try turning it off and back on?"). I gave up.
 
Last edited:
I enabled IPv6 using the "Passthrough" settings, but my Windows 11 PC and my Android 10 phone both failed every IPv6 test I tried, even though I could ping IPv6 IP addresses from the router. Tried all the usual dumb stuff ("Did you try turning it off and back on?"). I gave up.

Read thru this thread over on Reddit - it's entirely possible to get IPv6 working with google fiber...

 
Read thru this thread over on Reddit - it's entirely possible to get IPv6 working with google fiber...

Thanks, but I had already seen that. I'm on Win11 and I'm not even getting a public IPv6 IP address. Moreover, I don't even see a request being made to try getting an IP address. And the router's IPv6 log shows the router's public IPv6 IP address, but also says "No IPv6 clients."

I don't know what's going on. The only troubleshooting I want to try is one I'm loathe to try -- temporarily disabling the IPv6 firewall in the router. But then again, I'm not even seeing a DHCPv6 request being made from Win11.

IPv6 support is of course enabled in the Ethernet adapter. Teredo is disabled.
 
I noted that my router's IP address was 2604:xxxx:xxxx:xxxx::1, so I went into my Ethernet adapter's IPv6 settings and manually set the Win11 machine's IP address to 2604:xxxx:xxxx:xxxx::2, and plugged in a couple DNS servers (Quad9, 2620:fe::fe and 2620:fe::9). That worked, and it gave me IPv6 connectivity, but obviously this is an untenable workaround. And as soon as I revert it to using DHCP, IPv6 breaks again. Also:

Code:
C:\Temp>ipconfig /renew6


Windows IP Configuration


An error occurred while renewing interface Ethernet : The parameter is incorrect.

Anyone know why DHCPv6 isn't working?
 
Last edited:
Have you powered down the network for as long as you can (I would aim for an hour or more). Then, plug and power everything back up?

Leaving the RT-AX86U with IPv6 enabled (but powered down also)?

If that doesn't work, does a full reset work? Without using any backup config files?

Does RMerlin firmware work (again, flash, then perform a full reset, do not import any backup config files).
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top