IPV6 getting lost after a few days

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Ellsworth

Occasional Visitor
Twice now since running 386.1 and 386.1_2 I have completely lost IPV6 connections. It seems to happen every few days. I know that is IPV6 because I run the tests at ipv6-test.com. Tests work properly just after restarting the router and for a while thereafter. However, after a longer while (usually around 4-5 days) I have no connections on IPV6 and ipv6-test.com fails every test on IPV6. I restart the router and everything is working again. This is on an RT-AC68U.
 

learning_curve

Occasional Visitor
Twice now since running 386.1 and 386.1_2 I have completely lost IPV6 connections. It seems to happen every few days. I know that is IPV6 because I run the tests at ipv6-test.com. Tests work properly just after restarting the router and for a while thereafter. However, after a longer while (usually around 4-5 days) I have no connections on IPV6 and ipv6-test.com fails every test on IPV6. I restart the router and everything is working again. This is on an RT-AC68U.
I have the same router / firmware combination as yourself but IPv6 runs perfectly for me
What's your IPv6 setup? Can you post some sanitized pics of:
/Advanced_IPv6_Content.asp
/Main_IPV6Status_Content.asp
 

Ellsworth

Occasional Visitor
IPV6 used to run fine on 384. It has locked up again in 386.1_2 since I first wrote. Here are the IPV6 settings pictures you wanted:

The one thing that is not standard is that I use Spectrum and their IPV6 is through Charter. Charter does not provide DNS on IPV6 so I have to fill in with Google IPV6 DNS and others. I have also attached pictures of ipv6-test.com when it is not working and when it is working.
 

Attachments

  • 2021-02-21 14_22_06-ASUS Wireless Router RT-AC68U - IPv6.png
    2021-02-21 14_22_06-ASUS Wireless Router RT-AC68U - IPv6.png
    27.5 KB · Views: 67
  • 2021-02-21 14_28_16-ASUS Wireless Router RT-AC68U - IPv6 Network Information.png
    2021-02-21 14_28_16-ASUS Wireless Router RT-AC68U - IPv6 Network Information.png
    29.3 KB · Views: 78
  • 2021-02-21 14_55_16-IPv6 test - IPv6_4 connectivity and speed test.png
    2021-02-21 14_55_16-IPv6 test - IPv6_4 connectivity and speed test.png
    152.3 KB · Views: 69
  • 2021-02-21 14_57_31-IPv6 test - IPv6_4 connectivity and speed test.png
    2021-02-21 14_57_31-IPv6 test - IPv6_4 connectivity and speed test.png
    165.9 KB · Views: 57
Last edited:

learning_curve

Occasional Visitor
IPV6 used to run fine on 384. It has locked up again in 386.1_2 since I first wrote. Here are the IPV6 settings pictures you wanted: The one thing that is not standard is that I use Spectrum and their IPV6 is through Charter. Charter does not provide DNS on IPV6 so I have to fill in with Google IPV6 DNS and others. I have also attached pictures of ipv6-test.com when it is not working and when it is working.
Yes, I also ran IPv6 on 384.19 previously with no issues, just like you. The IPv6 test site that you've used, yes, I have used too (amongst others) again, with no problems when using either 384.19 or 386.1_2.

The 1st item (seeing as we are using the same router & firmware) is at the top of your 1st image. For whatever reason, you appear to be missing two records on there: 'Interface' & 'Accept default routes' - I've attached a quick screen grab for reference:
IPv6.png
I've previously found, that the value selected via the 'Interface' record is vital to configure IPv6 to suit the config of your own ISP (although pretty sure you'll be able to select / change via ssh if / when needed).

The 'Accept default routes' choice too, but that's of a much lower level of importance. Did you have these two records present in your GUI, prior to you switching over to 386.1_2 ? I did on 384.19.

The second item is nowhere near as important as the first, but might be relative (depending on the answers to the first item). Do you need a 2nd DNS provider / have you tried using just one DNS provider? Again, I've attached a quick screen grab of my own for a comparative reference. IPv6 DNS servers are provided by my own ISP, but I've opted out of using them. I use Cloudfare/APNIC as the only IPv6 DNS provider instead.

From what you've posted above, your ISP (and their partners) do not provide IPv6 DNS servers, so you have to opt out, by default, meaning that you have to use Google & Quad9 DNS servers, or maybe, just Google OR Quad9? The opting out works fine for me, but I am intentionally only using one DNS provider.
DNS.png
 

Ellsworth

Occasional Visitor
I am sorry. I have been switching back and forth between 386.1 and 386.1_2 and those are pictures of 386.1 on my router. But, there is no difference in the screens between the two versions.

The 1st item (seeing as we are using the same router & firmware) is at the top of your 1st image. For whatever reason, you appear to be missing two records on there: 'Interface' & 'Accept default routes' - I've attached a quick screen grab for reference:

I think the difference is the fact that your "WAN - Internet Connection" is not the same as I am using. You have a selection using PPP on the IPV6 setup and I do not even have that selection as on my picture of the IPV6 settings. I am using "Automatic IP" and I think you are using "PPTP" for your "WAN Connection Type" but it is possible that your provider provides a different connection type and I am pretty sure that you are not using "Automatic IP". So those other selections are not available on my setup.

From what you've posted above, your ISP (and their partners) do not provide IPv6 DNS servers, so you have to opt out, by default, meaning that you have to use Google & Quad9 DNS servers, or maybe, just Google OR Quad9? The opting out works fine for me, but I am intentionally only using one DNS provider.

The IPV6 DNS servers I am using currently are there because I -sometimes- get a hostname for IPV6 if i use another DNS server with the Google DNS Servers. I say -sometimes- because it never appears if I just use the Google Servers. If I add another server like Quad 9 DNS server then sometimes I get a hostname in the ipv6-test.com, but not all of the time. I have been attempting to find if I can make it a little bit more permanent, but no luck so far. The picture I provided is where it did not get an IPV6 hostname.
 
Last edited:

learning_curve

Occasional Visitor
I think the difference is the fact that your "WAN - Internet Connection" is not the same as I am using.
Yes, sorry I hadn't gone that far backwards in the chain. I shout have included those details too.
You have a selection using PPP on the IPV6 setup and I do not even have that selection as on my picture of the IPV6 settings.
On this specific router, there is no PPPoE support for IPv6, that's why I am using PPP. I believe other (later) Asus routers do now support PPPoE as a WAN mode for both IPv4 and IPv6.
I am using "Automatic IP" and I think you are using "PPTP" for your "WAN Connection Type" but it is possible that your provider provides a different connection type and I am pretty sure that you are not using "Automatic IP". So those other selections are not available on my setup.
Yes that's almost correct. I'm using PPPoE for "WAN Connection Type" not PPTP although I can and do use VPN too - separately. I use PPPoE despite me having a Static IPv4 address. This is purely because I am using IPv6 too, but, without the router's ability to support PPPoE for IPv6... Otherwise I could successfully use the Static IP "WAN Connection Type" for both IPv4 and IPv6.

I do have a static IPv6 address (of sorts) too, but only static as far as a firm, non-variable LAN IPv6 Prefix is concerned (hence a fixed pool of IPv6 addresses from the router) but, my own WAN IPv6 address can change, after a router re-boot (unlike IPv4) but, it changes only within the relative WAN IPv6 pool itself (if it does). This does NOT affect the LAN IPv6 Prefix and thus the fixed pool of IPv6 addresses provided by the router to change, but the WAN IPv6 address change is enough to make getting DDNS via IPv6 to run properly, a lot more challenging that it otherwise would be...

Moving back to your initial point, yes, there's quite a lot of differences, both visible and knock-on (e.g. IPv6 as you've mentioned) as a result of two different WAN Connection Types: Automatic IP and PPPoE. That means, any chance of us identifying a subtle difference in our same router / same firmware setups as the cause of your IPv6 failures, has now massively diminished, sadly...
The IPV6 DNS servers I am using currently are there because I -sometimes- get a hostname for IPV6 if i use another DNS server with the Google DNS Servers. I say -sometimes- because it never appears if I just use the Google Servers. If I add another server like Quad 9 DNS server then sometimes I get a hostname in the ipv6-test.com, but not all of the time. I have been attempting to find if I can make it a little bit more permanent, but no luck so far. The picture I provided is where it did not get an IPV6 hostname.
I see. However I'm not sure having a hostname for IPv6 is that important is it? It's only relative to your specific device and its absence doesn't affect your score rating on that specific test site at all, or indeed, affect anybody's ability to reach you AFIK. I haven't had a specified IPv6 hostname - by choice. You can try here for some further reference IPv6 Tests: https://test-ipv6.com & https://tools.keycdn.com/ipv6-ping & you'll see that having a hostname is not a factor with either.

FWIE It might still be worth giving the 'only 1 DNS provider (IPv4 & IPv6) & a then router re-boot a quick shot and seeing what happens to your IPv6 reliability?
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top