ISP's DHCP did not function properly

vrapp

Senior Member
Whenever there's some change with the cable modem, when it reboots and, perhaps, acquires new dynamic IP from the provider Comcast, it's followed by AC-68P being unable to establish WAN connection, with the message "ISP's DHCP did not function properly." This is always eventually fixed, usually by powering off cable modem and multiple efforts for 20-30 minutes. It never happens "by itself" without me doing something to the cable modem.
Internet search for this exact message shows 1,570 results, and it's only with Asus routers. Just to try it out, I tried Tomato firmware, and did not see it even once (meaning, any problem or delay with establishing WAN connection). But with stock firmware as well as with Merlin's, it's pretty much guaranteed.
If Merlin decides to take it on, I would be happy to provide any diagnostics etc.

This issue had already been discussed on this forum, and more than once, but as with all discussions about it in all places, it eventually "settled" with the asker having found some special combination of parameters that seemingly helped. I want to stress, once again, that this problem, or perhaps just this message with various different problems behind it, is very, very widespread.
 
Last edited:

zperetz

New Around Here
The error is very common and does not show something specific, so the reasons could be very-very different. Last 3 times I've seen this error it was linked to IPv6, when it was enabled on router and was not supported by provider. The issue was solved by disabling IPv6 on the router.
 

vrapp

Senior Member
The error is very common and does not show something specific, so the reasons could be very-very different. Last 3 times I've seen this error it was linked to IPv6, when it was enabled on router and was not supported by provider. The issue was solved by disabling IPv6 on the router.

If so, then perhaps the improvement might be in more detailed error message, pointing the user to the real cause. The firmware does know what it did not like, which led to showing this message, so why not to tell.
 

Jeff91101

New Around Here
THIS SOLUTION WORKED FOR ME - I struggled with this error on Spectrum, eventually changing my cable modem, having a tech look over wiring and signal strength, etc. Internet worked fine with a single computer directly plugged to the cable modem, but wouldn't work at all with my Asus router (yielding the dreaded "ISP's DHCP did not function properly" error) and wouldn't work with my backup router. When I reinstalled the Asus router I tried the Internet before plugging in any Ethernet connections, and worked. I had tried all other solutions seen online with respect to changing WAN settings (TTL and DHCP frequency), cycling WAN on/off to refresh the connection, and turning off IPv6. Nothing had worked. So, I've concluded that I must have a wired device connected to my network that is causing address conflicts. One clue that I had missed was that the wired network connection was showing up as an "unidentified" network rather than showing the network SSID when the Internet failure started, but that didn't get my attention until I found that the error only occurred when Ethernet connections were made to the router. If nothing else works for you, you might try unplugging Ethernet connections...I've not seen that suggested in any other posts related to this error message, and it was what solved the problem for me.
 

Jeff91101

New Around Here
UPDATE - defective device turned out to be my Tivo Mini 92000, which apparently had some type of Ethernet communication failure. When that device is unplugged from my network, the Internet immediately came back online and the Asus router error cleared. Plug the Tivo Mini back in, and the Internet goes down again, sometimes immediately, sometimes after a delay. Contacted Tivo support and was told that this is a rare but known issue with the device.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top