Issue with SSH on RT-AC68U

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Bold7384

New Around Here
I am having an issue with SSH on my RT-AC68U. I only noticed it after upgrading to 386.1_2, but after downgrading to 386.1 the issue persists. For SSH, I use cert based auth, have password login disabled, and brute force protection enabled. I tried wiping all settings and going with base configuration and still had the issue. I assume this is limited to my setup because I would expect more reports of this issue, but I am stumped on what might be causing this.

The behavior is consistent in that it is consistently failing, but it is inconsistent in how it behaves. Sometimes I am unable to connect to SSH via putty at all. Sometimes I get prompted for the login and then it fails. Sometimes I get prompted for the login and after entering that I am prompted for the cert password and then it fails. Sometimes I get to the command line and then fails while typing first command. When I say "fails" I mean it stops responding and eventually just times out.

Other steps I've tried:
* Removing USB drive
* I've restored default settings 2 or 3 times.
* I've downgraded and upgraded between 386.1 and 386.1_2 2 or 3 times.
* Enabled/Disabled ipv6
* Enabled/Disabled Asusnat Tunnel
* Enabled/Disabled IPv6 Neighbor solicitation
(Might seem like odd steps, but I was grasping at straws)

I have more troubleshooting steps to try, but if anyone has any suggestions I would greatly appreciate them.

Thanks for the support!
 

eibgrad

Very Senior Member
I assume by "cert based auth" and "prompted for password", you mean private/public keypair using a passphrase.

Forget the use of private/public keypair for the moment. Does simple username/password work correctly, and consistently?
 

Jeffrey Young

Senior Member
What does the syslog entries say? Look for entries concerning dropbear.
 
Last edited:

Wallace_n_Gromit

Senior Member
Have you noticed if the [Tools] [Sysinfo] [Internal Storage] [JFFS] is unmounted?
 
Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top